helpf.pro
Регистрация
FAQ 1С Все версии » Категорий: 85
Найти...

Все версии7.x8.x ОП8.2 УП8.3 УПВидео   Добавить FAQ
1С ERP Управление предприятием 2.0 » 5Отчеты » 2
1С Бухгалтерия 2.0 » 33Перечисления » 8
1С Бухгалтерия 3.0 » 6Планы видов расчета » 3
1С Зарплата и Управление Персоналом 2.5 » 74Планы видов характеристик » 1
1С Зарплата и Управление Персоналом 3.0 » 7Планы счетов » 0
1С Общие вопросы - Обычные формы » 76Полезные, Универсальные Функции » 75
1С Общие вопросы - Управляемые формы и Такси » 18Пользователь, роль доступа, интерфейс » 22
1С Управление производственным предприятием » 4Проводка » 0
1С Управление торговлей 10.3 » 21Прочие вопросы » 11
1С Управление торговлей 11 » 4Работа с Microsoft Office и OpenOffice » 74
COM-объекты, WMI, WSH » 64Работа с Датами (Временем) » 62
Enterprise Development Tools » 1Работа с Деревом Значений » 13
HTML, JS, VML » 7Работа с Интернет, Почтой (Mail), FTP » 41
Linux: CentOS, Debian, Ubuntu, ALT и д.р » 4Работа с Массивом, Структурой, Соответствием » 22
OLE, ActiveX » 5Работа с Списком Значений » 5
Web клиент » 0Работа с Таблицей Значений » 31
WEB-сервисы, WS-ссылки, XDTO-пакеты » 15Работа с Текстом (Строкой) » 37
XML, DBF, TXT, CSV » 32Работа с Типами данных » 6
Администрирование » 148Работа с Файлами и Каталогами » 33
Библиотека стандартных подсистем (БСП) » 0Работа с Формой (Диалог) и её элементами » 99
Бизнес-процессы » 4Работа с Хранилищем Значений » 15
Виды расчетов » 6Работа с Числами » 25
Виды Субконто » 2Работа со свойствами и категориями объектов » 0
Внешние источники данных » 4Регистры » 31
Внешние компоненты » 3Регистры бухгалтерии » 23
Внешние печатные формы, отчеты и обработки заполнения » 7Регистры накопления » 17
Встроенные Функции » 66Регистры расчета » 14
Географическая схема » 10Регистры сведений » 36
Группы расчетов » 1Регламентные задания, Фоновые задания » 3
Диаграмма » 14Регулярные выражения » 12
Документы » 73Реквизиты (свойства, представление) » 1
Журналы расчетов » 14Системные Ошибки » 37
Загрузка данных в 1С » 1Список Справочника, Документов, Регистров » 27
Задачи » 4Справочники » 57
Запросы » 87Схема Компоновки Данных » 70
Календари » 0Табличный документ » 38
Конвертация данных, Обмен, Перенос » 32Текстовый документ » 5
Константы » 7Торговое оборудование » 2
Мероприятия: семинары, форумы, конференции » 0Управляемое приложение, Тонкий клиент » 25
Метаданные » 12Форматированный документ » 4
Мобильное приложение » 5Функциональные опции » 0
Обработки » 6Штрих-код (barcode) » 6
Операция » 2
Категория: Документы
Версии: 8.x

1. Добавим строку в табличную часть документа // Док - ссылка на документ ОбъектДок = Док.ПолучитьОбъект(); НоваяСтрока = ОбъектДок.Товары.Добавить(); // Заполнить значения реквизитов. НоваяСтрока.Количество = 13; НоваяСтрока.Цена = 5500;
Подробнее  Разместил: E_Migachev  Дата: 19.02.2009  Прочитано: 129561  Комментарии: 2
0 
Распечатать
Категория: Документы
Версии: 8.x

ДокОбъект = СсылкаНаДокумент.ПолучитьОбъект(); ДокОбъект.Ответственный = глТекущийПользователь; ДокОбъект.Комментарий = "Исправление от "+Строка(ТекущаяДата()); ДокОбъект.Записать(); // или //ДокОбъект.Записать(РежимЗаписиДокумента.Проведен
Подробнее  Разместил: E_Migachev  Дата: 19.02.2009  Прочитано: 32857  Комментарии
0 
Распечатать
Категория: Документы
Версии: 8.x

// Выборка документов за весь период Выборка = Документы.НачислениеОтпуска.Выбрать(); Пока Выборка.Следующий() Цикл //Модуль обработки КонецЦикла; // Выборка документов за период с Даты начала по Дата окончания //Выборка = Документы.Расходная
Подробнее  Разместил: E_Migachev  Дата: 19.02.2009  Прочитано: 88883  Комментарии
+2 
Распечатать
Категория: Документы
Версии: 8.x

// Найти и открыть документ Результат = Документы.РасходнаяНакладная.НайтиПоНомеру(НомерДок, РабочаяДата); Если Результат.Пустая() Тогда Предупреждение("Документ не найден!"); Иначе Результат.ПолучитьФорму().Открыть(); КонецЕсли; //Найти до
Подробнее  Разместил: E_Migachev  Дата: 19.02.2009  Прочитано: 39136  Комментарии
0 
Распечатать
Категория: Документы
Версии: 8.x

Форма = Документы.РасходныйКассовыйОрдер.ПолучитьФорму(); //возможные варианты получения формы: Параметы () //Форма = Документы.РасходныйКассовыйОрдер.ПолучитьФормуВыбора(); //Форма = Документы.РасходныйКассовыйОрдер.ПолучитьФормуНовогоДокумент
Подробнее  Разместил: E_Migachev  Дата: 19.02.2009  Прочитано: 21475  Комментарии: 4
0 
Распечатать
Категория: Документы
Версии: 8.x 8.2 УП

Для 8.2: Открыть форму нового документа и предоставить пользователю самому интерактивно записать данные объекта в базу данных: проще всего использовать метод глобального контекста ОткрытьФорму(). Это можно сделать на клиенте. ОткрытьФорму(" Док
Подробнее  Разместил: E_Migachev  Дата: 19.02.2009  Прочитано: 129736  Комментарии: 4
+6 
Распечатать
Категория: Документы
Версии: 8.x

ДокументСсылка.Метаданные().Имя; // пример: РеализацияТоваровУслуг ДокументСсылка.Метаданные().ПолноеИмя(); // пример: Документ.РеализацияТоваровУслуг
Подробнее  Разместил: E_Migachev  Дата: 19.02.2009  Прочитано: 30877  Комментарии
+1 
Распечатать
Категория: Полезные, Универсальные Функции
Версии: 7.x 8.x

Функция глРазложить(Знач Стр, Разделитель = " ," ) Экспорт СЗ = СоздатьОбъект(" СписокЗначений" ); Если Разделитель = " " Тогда Стр = СокрЛП(Стр); Пока 1=1 Цикл Поз = Найти(Стр,Разделитель); Если Поз=0 Тогда СЗ.ДобавитьЗначение(Стр); Воз
Подробнее  Разместил: E_Migachev  Дата: 18.12.2008  Прочитано: 50736  Комментарии: 3
+2 
Распечатать
Категория: Полезные, Универсальные Функции
Версии: 7.x 8.x 8.2 УП

НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = " " ;
Подробнее  Разместил: E_Migachev  Дата: 18.12.2008  Прочитано: 84551  Комментарии: 3
+6 
Распечатать
Категория: Встроенные Функции
Версии: 7.x

// Присвоить значение переменной по ее имени. // в глоб.модуль: Функция Присвоить(Чему,Что) Экспорт Чему = Что; Возврат ""; КонецФункции // варианты вызова: // Шаблон(" "); // Шаблон(" "); // Пример: пусть у нас на форме есть 5 числовых рек
Подробнее  Разместил: E_Migachev  Дата: 11.12.2008  Прочитано: 19620  Комментарии
0 
Распечатать
Всего 1884 на 189 страницах по 10 на каждой странице