helpf.pro
Регистрация
 +1 
Распечатать

Печать штрихкода

1. Для того чтобы вставить объект для печати штрихкода в табличный документ выполните последовательно следующие действия: Меню Таблица - Рисунки - Вставить объект
Если библиотека 1C Bar Code установлена корректно, в списке выбора внешних объектов появится строка "1С.V8.Печать штрих-кодов" (режим выбора как элемент управления):
2. Разместите рисунок объекта в нужной области печатной формы, установить размер колонки и рисунка так, чтобы ширина одного и другого не мешали выводу на печать
3. Далее необходимо внести изменения в код внешней обработки, которую планируется подключить в качестве внешней печатной формы. Первым делом нужно отредактировать текст запроса, добавив туда информацию из регистра сведений "Штрихкоды". Это позволит использовать два нужных нам измерения - сам штрихкод и тип штрихкода.
Код 1C v 8.х
 Запрос.Текст = "ВЫБРАТЬ
| РеализацияТоваровУслугТовары.НомерСтроки,
| РеализацияТоваровУслугТовары.Номенклатура.Артикул КАК Артикул,
| РеализацияТоваровУслугТовары.Номенклатура,
| РеализацияТоваровУслугТовары.Номенклатура.НаименованиеПолное КАК Товар,
| РеализацияТоваровУслугТовары.Количество,
| РеализацияТоваровУслугТовары.ЕдиницаИзмерения КАК ЕдиницаЦены,
| МестаХраненияНоменклатуры.МестоХранения.Наименование КАК Склад,
| Штрихкоды.Штрихкод,
| Штрихкоды.ТипШтрихкода
|ИЗ
| Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.МестаХраненияНоменклатуры КАК
МестаХраненияНоменклатуры
| ПО РеализацияТоваровУслугТовары.Номенклатура =
МестаХраненияНоменклатуры.Номенклатура
| И РеализацияТоваровУслугТовары.Склад =
МестаХраненияНоменклатуры.Склад
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.Штрихкоды КАК Штрихкоды
| ПО РеализацияТоваровУслугТовары.Номенклатура = Штрихкоды.Владелец
| И РеализацияТоваровУслугТовары.ЕдиницаИзмерения.ЕдиницаПоКлассификатору =
| Штрихкоды.ЕдиницаИзмерения.ЕдиницаПоКлассификатору
|ГДЕ
| РеализацияТоваровУслугТовары.Ссылка = &СсылкаНаОбъект
|УПОРЯДОЧИТЬ ПО
| Склад УБЫВ";


После внесения изменений в макет и запрос обработки, требуется отредактировать способ заполнения данными областей макета с учетом внесенных изменений. Самое интересное в этом примере кода процедуры - способ передачи данных в объект рисунка печати штрихкода:
Код 1C v 8.х
 // Строки накладной
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
ОбластьМакета = Макет.ПолучитьОбласть("Строка");
ОбластьМакета.Параметры.Заполнить(Выборка);

Если Выборка.ТипШтрихкода <> NULL И Выборка.Штрихкод <> NULL Тогда
ОбластьМакета.Рисунки.D1.Объект.ТипКода = Выборка.ТипШтрихкода.Код;
ОбластьМакета.Рисунки.D1.Объект.ТекстКода = Выборка.Штрихкод;
иначе
ОбластьМакета.Рисунки.D1.Объект.ТипКода = 0;
ОбластьМакета.Рисунки.D1.Объект.ТекстКода = "00000000";
КонецЕсли;

ТабДок.Вывести(ОбластьМакета);
КонецЦикла;

Все, больше ничего не надо, сохраняем и формируем
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 24262
 +1 
Распечатать
Возможно, вас также заинтересует
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Выборка документа по номеру и вывод на Печать, в Табличный Документ 0
Процедура Печать() Если (ПустоеЗначение(ДатаНач)=1) или (ПустоеЗначение(ДатаКон)=1) Тогда Предупреждение(" Не задан период отчета" ); Возврат; КонецЕсли; Заг=" За период с " +ДатаНач+" по " +ДатаКон; Таб=СоздатьОбъект("...
Выбрать Остатки и Обороты по указанным счетам, отбор по субконто и выгрузка результата в EXCEL 0
Запрос=Новый Запрос; Запрос.Текст=" |ВЫБРАТЬ | ХозрасчетныйОстаткиИОбороты.Счет, | ХозрасчетныйОстаткиИОбороты.Субконто1, | ХозрасчетныйОстаткиИОбороты.Субконто2, | ХозрасчетныйОстаткиИОбороты.Субконто3, ...
Вывести справочник в таблицу, табличный документ 0
//Выведем весь справочник Номенклатура Запрос=новый Запрос; Запрос.Текст=" |ВЫБРАТЬ | Номенклатура.* |ИЗ | Справочник.Номенклатура КАК Номенклатура |" ; РезультатЗ = Запрос.Выполнить(); //Далее использовать функцию...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.