helpf.pro
Регистрация
 0 
Распечатать

Выбор из нескольких списков документов для открытия?

Код 1C v 8.х
 Док = Метаданные.Документы; 
СписокДокументов = Новый СписокЗначений();

СписокДокументов.Добавить(Док.ПлатежноеПоручениеИсходящее, , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеПоручениеВходящее, , Ложь);
СписокДокументов.Добавить(Док.АккредитивПереданный, , Ложь);
СписокДокументов.Добавить(Док.АккредитивПолученный, , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеТребованиеВыставленное, , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеТребованиеПолученное, , Ложь);
СписокДокументов.Добавить(Док.ИнкассовоеПоручениеПереданное, , Ложь);
СписокДокументов.Добавить(Док.ИнкассовоеПоручениеПолученное, , Ложь);
СписокДокументов.Добавить(Док.ПлатежныйОрдерСписаниеДенежныхСредств, , Ложь);
СписокДокументов.Добавить(Док.ПлатежныйОрдерПоступлениеДенежныхСредств, , Ложь);

Если СписокДокументов.ОтметитьЭлементы("Укажите, какие списки документов открыть") Тогда
Для Каждого НазваниеДокумента из СписокДокументов Цикл
Если НазваниеДокумента.Пометка Тогда
ФормаСписка = Документы[НазваниеДокумента.Значение.Имя].ПолучитьФормуСписка();
ФормаСписка.Открыть();
КонецЕсли;
КонецЦикла;
КонецЕсли;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7002
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 5
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
ZIP-архив Чтение 0
Для того чтобы прочитать файлы из ZIP-архива необходимо выполнить несколько простых действий: - Открыть необходимый архив - Распаковать файлы Создание объекта ЧтениеZIPФайла можно осуществить двумя путями - создать...
Автоматическая архивация баз 1С с использованием Cobian Backup и VBS скриптов 6
Клиент попросил настроить автоматическую архивацию баз 1С раз в три дня и выгрузку архивов на Dropbox и на FTP Сервер. Кроме 1С нужно архивировать папку с рабочими документами. Хочет - так хочет, делаем: Первым делом...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.