helpf.pro
Регистрация
 +3 
Распечатать

Ввод документа на основании - Программно

Код 1C v 8.х
 НовДок = Документы.ПеречислениеНДФЛвБюджет.СоздатьДокумент();
//Заполнить - вызывает ОбработкаЗаполнения(Основание) в документе ПеречислениеНДФЛвБюджет
НовДок.Заполнить(ЭлементыФормы.ДокументСписок.ТекущаяСтрока);
НовДок.ПолучитьФорму().Открыть();


//Пример модуля документа ПеречислениеНДФЛвБюджет
Процедура ОбработкаЗаполнения(Основание)
Если ТипЗнч(Основание) = Тип("ДокументСсылка.ЗарплатаКВыплатеОрганизаций") Тогда
// Заполнение шапки
Комментарий = Основание.Комментарий;
КраткийСоставДокумента = Основание.КраткийСоставДокумента;
Организация = Основание.Организация;
Ответственный = Основание.Ответственный;
ДатаПлатежа = Основание.ПериодРегистрации;
МесяцНалоговогоПериода = Основание.ПериодРегистрации;
Для Каждого ТекСтрокаЗарплата Из Основание.Зарплата Цикл
НоваяСтрока = СотрудникиОрганизации.Добавить();
НоваяСтрока.Сумма = ТекСтрокаЗарплата.Сумма;
НоваяСтрока.ФизЛицо = ТекСтрокаЗарплата.Физлицо;
КонецЦикла;
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 16013
 +3 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.