helpf.pro
Регистрация
 0 
Распечатать

Создание Word документа из 1С и подключение обработчика события word

Код 1C v 8.х
 // Пример оздания Word документа из 1С и подключение обработчика события word

// Если у документ Word до сих пор не создан
Если WordДокумент = Неопределено Тогда

// Открыть Word
MSWord = Новый COMОбъект("Word.Application");
MSWord.Visible = Истина;

// Удалить временный файл, если есть
Если ВременныйФайл <> Неопределено Тогда
УдалитьФайлы(ВременныйФайл);
КонецЕсли;

// Получить имя временного файла для хранения документа
ИмяФайла = ПолучитьИмяВременногоФайла(".doc");

// Получим данные файла
ДанныеФайла = СправочникОбъект.Файл.Получить();
Если ДанныеФайла = Неопределено Тогда
// Создать новый документ, если не был создан до этого
WordДокумент = MSWord.Documents.Add();
// И сохранить его во временный файл
WordДокумент.SaveAs(ИмяФайла);
Иначе
// Записать данные во временный файл
ДанныеФайла.Записать(ИмяФайла);

// Открыть документ Word и добавить обработчик закрытия документа
WordДокумент = MSWord.Documents.Open(ИмяФайла);
КонецЕсли;

// Добавим обработчик события от документа Word
ДобавитьОбработчик WordДокумент.Close, ЗакрытиеДокумента;

КонецЕсли;

// Если документ открыт, активизировать его
WordДокумент.Activate();
WordДокумент.Application.Activate();
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 9518
 0 
Распечатать
Возможно, вас также заинтересует
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
SMTP greeting failure: 421 SMTP connection broken (reply) 2
Опи­са­ние ошиб­ки: С сен­тяб­ря 2014 Ян­декс.Почта, Mail.ru пе­ре­шли на про­то­кол SSL, что сде­ла­ло их еще более без­опас­ны­ми. Чтобы и даль­ше ра­бо­тать с пись­ма­ми через 1С, Вам нужно из­ме­нить их на­строй­ки и...
Автоматическая архивация баз 1С 8.х для файлового и клиент-серверного варианта 3
Данный способ архивации подходит для файловых и SQL версий баз 1С: И так: 1. Создаем скрипт vbs и сохраняем его в C:BackupZUP.vbs Set WshShell = CreateObject(" WScript.Shell" ) dim d,m,y d = day(date()) if d 10 then d = " 0" d end
Автоматическая архивация баз 1С с использованием Cobian Backup и VBS скриптов 6
Клиент попросил настроить автоматическую архивацию баз 1С раз в три дня и выгрузку архивов на Dropbox и на FTP Сервер. Кроме 1С нужно архивировать папку с рабочими документами. Хочет - так хочет, делаем: Первым делом...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.