helpf.pro
Регистрация
 0 
Распечатать

Как найти все ссылки в ИБ на массив ссылок

Код 1C v 8.х
 // Параметры:
// пМассивСсылок – Массив – ссылок;
// пТаблицаРезультатов - ТаблицаЗначений - возвращаемая таблица с найденными ссылками.
//
Процедура НайтиПоСсылкам(пМассивСсылок, пТаблицаРезультатов) Экспорт

НайденныеСсылки = НайтиПоСсылкам(пМассивСсылок);
Если пМассивСсылок.Количество() < 2 Тогда
НачальнаяКолонка = 1;
Иначе
НачальнаяКолонка = 0;
КонецЕсли;
Для Сч = НачальнаяКолонка По НайденныеСсылки.Колонки.Количество() - 1 Цикл
пТаблицаРезультатов.Колонки.Добавить(НайденныеСсылки.Колонки[Сч].Имя);
КонецЦикла;
Для Каждого Строка Из НайденныеСсылки Цикл
НоваяСтрока = пТаблицаРезультатов.Добавить();
НоваяСтрока.Данные = ЗначениеВСтрокуВнутр(Строка.Данные);
НоваяСтрока.Метаданные = Строка.Метаданные.ПолноеИмя();
КонецЦикла;

КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7237
 0 
Распечатать
Возможно, вас также заинтересует
Google maps : вывод точек на карту и режим панорамы 7
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С возможностью просмотра панора
Google maps, поиск оптимального маршрута 5
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; * Координаты начальной и коне
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 10
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием обработки " Универсальный обме
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура РасчетШириныКолонок(Табличный
Алгоритм шифрования RC4 1
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации алгоритма шифрования RC4 на встроенном яз
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.