helpf.pro
Регистрация
 0 
Распечатать

Получение данных для расчета и Расчет

Собственно процесс расчета записей каждого поднабора состоит в получении всех необходимых данных для расчета каждой записи и вычислении значений ресурсов этой записи по формуле, определяемой способом расчета данной записи. Например, для расчета записи об окладе нужно будет получить данные графика этой записи, для расчета премии необходимо будет рассчитать базу и так далее.

Ниже приведен пример процедуры, осуществляющей расчет набора записей одного приоритета. Для каждой записи при помощи функции ПолучитьДанныеДляРасчета() возвращается структура данных, которая передается в процедуру РассчитатьЗапись().

Расчет набора записей одного приоритета
Код 1C v 8.х
 Процедура РассчитатьНаборЗаписей(НаборЗаписей, Приоритет, ТабличнаяЧасть = Неопределено)
Иначе

СтруктураДанных.Вставить("ОтработаноВремени", 0); СтруктураДанных.Вставить("НормаВремени", 0);

Для каждого Запись из НаборЗаписей Цикл
Если Запись.ВидРасчета.Приоритет = Приоритет Тогда

// Получить данные для расчета записи.
ДанныеДляРасчета = ПолучитьДанныеДляРасчета(Запись);

// Вызвать процедуру расчета записи. РассчитатьЗапись(Запись, ДанныеДляРасчета);

// Возвратить результат расчета в табличную часть документа. Если Не ТабличнаяЧасть = Неопределено Тогда
СтрокаТабличнойЧасти = ТабличнаяЧасть.Получить(Запись.НомерСтроки-1); СтрокаТабличнойЧасти.Результат = Запись.Результат;
КонецЕсли; КонецЕсли;
КонецЦикла;

КонецПроцедуры


В функции ПолучитьДанныеДляРасчета() должны быть прописаны алгоритмы, при помощи которых можно получить данные для расчета записи с любым способом расчета, существующим в конфигурации. Ниже приведен пример функции, которая получает данные для трех способов расчета:

Получение данных для трех видов расчета
Код 1C v 8.х
 Функция ПолучитьДанныеДляРасчета(Запись)

СпособРасчета = Запись.ВидРасчета.СпособРасчета; СтруктураДанных = Новый Структура;
Если СпособРасчета = Перечисления.СпособыРасчета.ПоМесячнойСтавке Тогда

// Получить данные графика.

Запрос = Новый Запрос("
|ВЫБРАТЬ
| ДанныеГрафика.ЗначениеФактическийПериодДействия КАК ГрафикФакт,
| ДанныеГрафика.ЗначениеПериодДействия КАК ГрафикНорма
|ИЗ
| РегистрРасчета.ОсновныеНачисленияРегл.ДанныеГрафика(
| Регистратор = &Регистратор
| И НомерСтроки = &НомерСтроки)
КАК ДанныеГрафика");

Запрос.УстановитьПараметр("Регистратор", Запись.Регистратор); Запрос.УстановитьПараметр("НомерСтроки", Запись.НомерСтроки);
Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда
СтруктураДанных.Вставить("ОтработаноВремени", Выборка.ГрафикФакт);
СтруктураДанных.Вставить("НормаВремени", Выборка.ГрафикНорма);

КонецЕсли;

ИначеЕсли

СпособРасчета = Перечисления.СпособыРасчета.ПроцентомОтБазы Тогда

Запрос = Новый Запрос("
|ВЫБРАТЬ
| База.РезультатБаза
|ИЗ
| РегистрРасчета.ОсновныеНачисленияРегл.БазаОсновныеНачисленияРегл(
| &Измерения, &Измерения, ,
| Регистратор = &Регистратор
| И НомерСтроки = &НомерСтроки) КАК База");

Измерения = Новый Массив(2); Измерения[0] = "ФизЛицо"; Измерения[1] = "Организация";

Запрос.УстановитьПараметр("Регистратор", Запись.Регистратор);

Запрос.УстановитьПараметр("НомерСтроки", Запись.НомерСтроки);

Запрос.УстановитьПараметр("Измерения", Измерения);

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда
СтруктураДанных.Вставить("База", Выборка.РезультатБаза);

Иначе

СтруктураДанных.Вставить("База", 0);

КонецЕсли;

ИначеЕсли СпособРасчета = Перечисления.СпособыРасчета.ПоСдельнойВыработке Тогда

// Получить данные регистра накопления
// фактическая выработка за период действия записи.

Запрос = Новый Запрос("

|ВЫБРАТЬ
| СУММА(СдельнаяВыработкаОбороты.ВыработкаОборот) КАК ВыработкаОборот
|ИЗ
| РегистрНакопления.СдельнаяВыработка.Обороты(
| &ДатаНачало, &ДатаКонец, ,
| Организация = &Организация И ФизЛицо = &ФизЛицо)
| КАК СдельнаяВыработкаОбороты");

Запрос.УстановитьПараметр("ДатаНачало", НачалоДня(Запись.ПериодДействияНачало));
Запрос.УстановитьПараметр("ДатаКонец", КонецДня(Запись.ПериодДействияКонец));
Запрос.УстановитьПараметр("ФизЛицо", Запись.ФизЛицо); Запрос.УстановитьПараметр("Организация", Запись.Организация);
Выборка = Запрос.Выполнить().Выбрать(); Если Выборка.Следующий() Тогда
СтруктураДанных.Вставить("Выработка", Выборка.ВыработкаОборот);
Иначе
СтруктураДанных.Вставить("Выработка", 0); КонецЕсли;

КонецЕсли;

Возврат СтруктураДанных;

КонецФункции // ПолучитьДанныеДляРасчета


В данном случае для расчета записей со способом ПоМесячнойСтавке система получит данные графика за период действия и фактический период действия, для способа ПроцентомОтБазы будет получена расчетная база записи, а для способа ПоСдельнойВыработке будут рассчитаны обороты по соответствующему регистру накопления за интервал периода действия записи. Способ расчета ФиксированнойСуммой не требует получения данных.
Функция ПолучитьДанныеДляРасчета() возвращает структуру, содер- жащую различные поля в зависимости от способа расчета, применяемого в данной записи

Расчет значений ресурсов записи
После того как данные для расчета получены, необходимо прописать в модуле формулу для заполнения реквизитов каждой записи в соответствии со способом расчета. В данном случае эту функцию выполняет процедура РассчитатьЗапись(). В процедуре РассчитатьЗапись() для каждого возмож- ного способа расчета описывается формула, позволяющая из реквизитов записи и полученных данных рассчитать значения ресурсов этой записи.

Процедура расчета записей
Код 1C v 8.х
 Процедура РассчитатьЗапись(Запись, ДанныеДляРасчета) СпособРасчета = Запись.ВидРасчета.СпособРасчета;
Если СпособРасчета = Перечисления.СпособыРасчета.ПоМесячнойСтавке Тогда
Если Не ДанныеДляРасчета.НормаВремени = 0 Тогда
Результат = Запись.Размер * ДанныеДляРасчета.ОтработаноВремени / ДанныеДляРасчета.НормаВремени;
Иначе
Результат = 0; КонецЕсли;

ИначеЕсли
СпособРасчета = Перечисления.СпособыРасчета.ПроцентомОтБазы Тогда
Результат = Запись.Размер * ДанныеДляРасчета.База / 100;

ИначеЕсли
СпособРасчета = Перечисления.СпособыРасчета.ФиксированнойСуммой Тогда
Результат = Запись.Размер;

ИначеЕсли
СпособРасчета = Перечисления.СпособыРасчета.ПоСдельнойВыработке Тогда
Результат = ДанныеДляРасчета.Выработка; КонецЕсли;

Запись.Результат = Результат * ?(Запись.Сторно, -1, 1);

КонецПроцедуры // Рассчитать запись


При расчете записей следует учитывать, что сторно-записи рассчитываются в общем порядке. Поэтому в ресурсы сторно-записи должно попадать отрицательное значение результата расчета. Например, сторно- запись отменяет начисленный оклад за период 5 дней. При расчете такой записи по формуле система получит сумму оклада за 5 дней, например, 1200 руб. В ресурс сторно-записи в этом случае должно быть записано значение -1200.
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 5418
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
В ЗУП не исчисляются суммы районного коэффициента и северной надбавки? 1
В Зарплата и управление персоналом 8 почему при расчете среднего заработка для начисления очередного отпуска не исчисляются суммы районного коэффициента и северной надбавки? При исчислении среднего заработка во...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.