helpf.pro
Регистрация
 0 
Распечатать

Формирование записей перерасчета

Код 1C v 8.х
 //Формирование записей перерасчета

Процедура СформироватьЗаписиПерерасчета()

// Запрос по записям регистра расчета. Запрос = Новый Запрос("
|ВЫБРАТЬ РАЗЛИЧНЫЕ
| СдельнаяВыработка.ФизЛицо,
| СдельнаяВыработка.Организация,
| ОсновныеНачисленияРегл.Регистратор,
| ОсновныеНачисленияРегл.ВидРасчета
|ИЗ
| РегистрНакопления.СдельнаяВыработка КАК СдельнаяВыработка
| ЛЕВОЕ СОЕДИНЕНИЕ
| РегистрРасчета.ОсновныеНачисленияРегл КАК ОсновныеНачисленияРегл
| ПО СдельнаяВыработка.ФизЛицо = ОсновныеНачисленияРегл.ФизЛицо
| И СдельнаяВыработка.Организация = ОсновныеНачисленияРегл.Организация
| И (СдельнаяВыработка.Период МЕЖДУ
| ОсновныеНачисленияРегл.ПериодДействияНачало
| И ОсновныеНачисленияРегл.ПериодДействияКонец)
|ГДЕ
| ОсновныеНачисленияРегл.ВидРасчета = &ВидРасчета
| И СдельнаяВыработка.Регистратор = &Регистратор
|ИТОГИ ПО
| Регистратор");

Запрос.УстановитьПараметр("ВидРасчета", ПланыВидовРасчета.ОсновныеНачисления.Сдельный);
Запрос.УстановитьПараметр("Регистратор", Ссылка);

ВыборкаДокументов = Запрос.Выполнить().
Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

// Получение объекта ПерерасчетМенеджер.
Перерасчет = РегистрыРасчета.ОсновныеНачисленияРегл.
Перерасчеты.ПерерасчетОсновныхНачислений;

Пока ВыборкаДокументов.Следующий() Цикл

// Создание набора записей.
НаборЗаписей = Перерасчет.СоздатьНаборЗаписей(); НаборЗаписей.Отбор.ОбъектПерерасчета.Значение = ВыборкаДокументов.Регистратор;

Выборка = ВыборкаДокументов.Выбрать();
// Создание записей перерасчета. Пока Выборка.Следующий() Цикл
Запись = НаборЗаписей.Добавить(); Запись.ВидРасчета = Выборка.ВидРасчета; Запись.Организация = Выборка.Организация; Запись.ФизЛицо = Выборка.ФизЛицо;
КонецЦикла;

// Запись в таблицу без замещения. НаборЗаписей.Записать(Ложь);

КонецЦикла;

КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 4089
 0 
Распечатать
Возможно, вас также заинтересует
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Автоматическая выгрузка загрузка данных используя регламентное задание 1
Для обмена данными между программами необходимо сделать следующее: 1. При помощи Конвертации Данных создать правила выгрузки данных 2. Нужно чтобы в конфигурации была обработка УниверсальныйОбменДаннымиXML ,...
Блокировка записей, невозможно изменить или удалить из регистра. Конфликт блокировок MS SQL + 1C 1
При попытке удалить запись из регистра сведений - получаю ошибку: она заблокирована, ошибка блокировок и т.д. Отключил всех пользователей, перезапустил сервер, пробую удалить - опять ошибка блокировки :( Путем тестов...
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.