helpf.pro
Регистрация
 0 
Распечатать

Получение количества календарных дней по производственному календарю

Код 1C v 8.х
 Функция КоличествоДнейПоКалендарнымДням(ДатаНачала, ДатаОкончания, ВключатьПраздники = Ложь)

Если НЕ ВключатьПраздники Тогда
Запрос = Новый Запрос(
"ВЫБРАТЬ
| СУММА(РегламентированныйПроизводственныйКалендарь.КалендарныеДни) КАК КоличествоДней
|ИЗ
| РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК РегламентированныйПроизводственныйКалендарь
|ГДЕ
| РегламентированныйПроизводственныйКалендарь.ДатаКалендаря >= &ДатаНачала
| И РегламентированныйПроизводственныйКалендарь.ДатаКалендаря <= &ДатаОкончания");

Запрос.УстановитьПараметр("ДатаНачала", ДатаНачала);
Запрос.УстановитьПараметр("ДатаОкончания", ДатаОкончания);

Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
КоличествоДней = Выборка.КоличествоДней;
Иначе
ОбщегоНазначенияЗК.СообщитьОбОшибке("Проверьте заполнение производственного календаря!");
КоличествоДней = Неопределено;
КонецЕсли;
Иначе
КоличествоДней = (НачалоДня(ДатаОкончания) - НачалоДня(ДатаНачала)) / 86400 + 1;
КонецЕсли;

Возврат КоличествоДней;

КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 3688
 0 
Распечатать
Возможно, вас также заинтересует
Как получить количество рабочих дней в месяце по календарю? 0
Для одного проекта потребовалось получить количество рабочих дней в месяце по календарю, без учета праздников. В результате получилась простая функция: Функция ПолучитьКолВоРабочихДнейПоКалендарю(ДатаМесяца) ...
Неправильно рассчитывает номер недели в году, функция корректного расчета 0
Для определения номера недели в конфигурациях 1С обычно используется стандартная функция НеделяГода(). Например 17 октября 2016 года: НеделяГода() возвращает 43 , а по обычному календарю это 42: Судя по всему, 1С...
Получить количество рабочих дней сотрудника 9
В данной статье описаны функции которые вы можете использовать в ЗУП для получения количества рабочих дней по графику работы сотрудника или по производственному календарю // Функции получения количества рабочих...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.