helpf.pro
Регистрация
 0 
Распечатать

Как добавить подписи в отчет СКД?

Во многих организациях сформированные отчеты заверяют подписями.
В данном примере я покажу как можно вывести подписи для типового отчета ЗУП Свод начислений.
Для начала создадим макет в котором и разместим подписи, макет я создам общий, т.к. он будет использоваться и в других отчетах.
Макет такой:
title

Открываем Отчет СводНачисленнойЗарплатыОрганизаций, открываем Форму и ищем процедуру ОбновитьОтчет()
После
Код 1C v 8.х
 СформироватьОтчет(ЭлементыФормы.Результат, ДанныеРасшифровки);   

добавляем вывод подписей
Код 1C v 8.х
 Макет = ПолучитьОбщийМакет("МакетПодписи");
ОбластьВывести = Макет.ПолучитьОбласть("Подпись");
ЭлементыФормы.Результат.Вывести(ОбластьВывести);


Полный код процедуры ОбновитьОтчет()
Код 1C v 8.х
 Процедура ОбновитьОтчет() Экспорт
СостояниеМодифицированности = Модифицированность;
Если ПанельНастроекНарисована <> Истина Тогда
ОбновлениеОтображения();
КонецЕсли;
ТиповыеОтчеты.ЗагрузитьВРеквизитЗначенияНастроекПанелиПользователя(ЭтотОбъект, ЭтаФорма);
ПараметрыПанели = ТиповыеОтчеты.ПолучитьПараметрыПанелиПользователяОбъекта(ОтчетОбъект);
ЗначенияНастроек = ТиповыеОтчеты.ПолучитьЗначенияНастроекПанелиПользователяОбъекта(ОтчетОбъект);
Отказ = ложь;
ТиповыеОтчеты.ПроверитьЗначенияПараметров(ЗначенияНастроек, ПараметрыПанели, Отказ);
Если Отказ тогда
Возврат;
КонецЕсли;
РежимформированияОтчета = НЕ ЭтоОтработкаРасшифровки;
СформироватьОтчет(ЭлементыФормы.Результат, ДанныеРасшифровки);
//Мигачев - Вывод подписей
Макет = ПолучитьОбщийМакет("МакетПодписи");
ОбластьВывести = Макет.ПолучитьОбласть("Подпись");
// Если надо вывести параметр
//ОбластьВывести.Параметры.Подписант = Бухгалтер;
ЭлементыФормы.Результат.Вывести(ОбластьВывести);
//*//
УправлениеОтчетами.УстановитьКолонтитулыПоУмолчанию(ЭлементыФормы.Результат, Заголовок, Строка(ПараметрыСеанса.ТекущийПользователь));
Модифицированность = СостояниеМодифицированности;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 7585
 0 
Распечатать
Возможно, вас также заинтересует
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Выбор оптимального алгоритма для разбора строки в массив 0
Столкнулся с проблемой: ПолучитьСтрокуПоНомеру() медленно отрабатывает на входных данных 100 000 строк. Как сделать бытсрее? // Пример Defender aka LINN ВремяНачала = ТекущаяДата(); Сообщить(" Обработка начата: " + ВремяНачала); ...
Вывести табличный документ в PDF 2
Данный пример работает на платформе выше 8.2.13 Макет = ПолучитьМакет(" Макет" ); ОбластьШапка = Макет.ПолучитьОбласть(" Шапка" ); ТабДок = Новый ТабличныйДокумент; ОбластьШапка.Параметры.НомерДок = Номер; ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.