helpf.pro
Регистрация
 0 
Распечатать

Функция дни рождения сотрудников

Данная функция написана для ЗиК 7.7

Код 1C v 7.x
 
//Функция подбирает окончание для возраста
Функция СтрГода(Возраст)
Остаток = Возраст%10;
Если Остаток = 1 Тогда
Стр = "год";
ИначеЕсли ((Остаток > 1) и (Остаток < 5)) Тогда
Стр = "года";
Иначе
Стр = "лет";
КонецЕсли;
Возврат Стр;
КонецФункции

//Формируем дни рождения Сотрудников
Процедура ДниРожденияСотрудников()
ТекстДР="";
Именинники = СоздатьОбъект("СписокЗначений");
СпрСотр = СоздатьОбъект("Справочник.Сотрудники");
СпрСотр.ВыбратьЭлементы();
Пока СпрСотр.ПолучитьЭлемент()= 1 Цикл
ТекЭлем = СпрСотр.ТекущийЭлемент();
Если ТекЭлем.ЭтоГруппа() = 0 Тогда
Если ((ТекЭлем.Родитель <> "Уволенные")) Тогда
ТекСотр = СпрСотр.ТекущийЭлемент();
Если (ПустоеЗначение(ТекСотр.СостояниеФизЛица.Получить(НачМесяца(ТекущаяДата()))) = 0) Тогда
Если (ДатаМесяц(ТекСотр.ДатаРождения) = ДатаМесяц(ТекущаяДата())) Тогда
Именинники.ДобавитьЗначение(ТекСотр);
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;
Если Именинники.РазмерСписка() <> 0 Тогда
ТекстДР=ТекстДР+" ********* СПИСОК ИМЕНИННИКОВ *********"+РазделительСтрок+" за месяц "+Формат(ТекущаяДата(),"ДММММ")+РазделительСтрок;
ТекстДР=ТекстДР+"-----------------------------------------------------------------------------------------------------------------------------------------------"+РазделительСтрок;
Для к = 1 по Именинники.РазмерСписка() Цикл
Сотр = Именинники.ПолучитьЗначение(к);
Возраст = (Число(ДатаГод(ТекущаяДата()))-Число(ДатаГод(Сотр.ДатаРождения)));
РазницаДней = (Число(ДатаЧисло(Сотр.ДатаРождения))-Число(ДатаЧисло(ТекущаяДата())));
СтрГода = СтрГода(Возраст);
Если (ДатаЧисло(Сотр.ДатаРождения) < ДатаЧисло(ТекущаяДата())) Тогда
ТекстДР=ТекстДР+" "+Сотр+" "+Сотр.ДатаРождения+" уже исполнилось "+Возраст+" "+СтрГода+"!"+РазделительСтрок;
Иначе
Если (РазницаДней = 2) Тогда
ТекстДР=ТекстДР+"ПОСЛЕЗАВТРА! "+Сотр+" послезавтра "+Сотр.ДатаРождения+" будет праздновать " + Возраст + "-й День Рождения!!!! ";

ИначеЕсли (РазницаДней = 1) Тогда
ТекстДР=ТекстДР+"ЗАВТРА! "+ Сотр + " будет отмечает свой " + Возраст + "-й День рождения!";
ИначеЕсли (РазницаДней = 0) Тогда
ТекстДР=ТекстДР+"СЕГОДНЯ! "+ Сотр + " отмечает свой " + Возраст + "-й День рождения!";
КонецЕсли;
ТекстДР=ТекстДР+" ( "+Сотр.Подразделение.Получить(ТекущаяДата())+" , "+Сотр.Должность.Получить(ТекущаяДата())+" )"+РазделительСтрок;
КонецЕсли;
КонецЦикла;
Иначе
ТекстДР=ТекстДР+"В текущем месяце именинников нет!";
КонецЕсли;
Сообщить(ТекстДР);
КонецПроцедуры


В файловом архиве есть и сама обработка.
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 18888
 0 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.