helpf.pro
Регистрация
 0 
Распечатать

Процедура заполняет WORD шаблон из СпискаЗначений

Заполняет Вордовский шаблон из СпискаЗначений
Вставляется в виде обрабтки. При открытии передается СЗ первым значением идет WORD, в строковом представлеии наименование файла шаблона. Затем идентификаторы закладок (поля) в тексте шаблона - в представлении что подставить.
Сперва хотел сделать что-то универсальное Ворд-Ексель, а потом передумал. Отого такой первый параметр в списке значений

Код 1C v 7.x
 Процедура ПриОткрытии()
Перем Закладка, ТектВывода, сз;
СтатусВозврата(0);
сз = Форма.Параметр;
ФайлШаблон = ""; ОЛЕ_Объект = "";
Если ТипЗначенияСтр(сз)<>"СписокЗначений" Тогда
Сообщить("Для формирования документа передайте подготовленный список значений", "!!!"); Возврат;
ИначеЕсли сз.РазмерСписка()=0 Тогда
Сообщить("Для формирования документа передайте подготовленный список значений", "!!!"); Возврат;
Иначе
ФайлШаблон = сз.ПолучитьЗначение(1, ОЛЕ_Объект);

Если ВРег(ОЛЕ_Объект) <> "WORD" Тогда
Сообщить("OLE объект "+ОЛЕ_Объект+" не поддерживается", "!!!"); Возврат;
КонецЕсли;

Если ФС.СуществуетФайл(КаталогИБ()+"Шаблоны" + ФайлШаблон) = 0 Тогда
Сообщить("Нет файла - шаблона " + ФайлШаблон, "!!!"); Возврат;
КонецЕсли

КонецЕсли;

OLE = СоздатьОбъект(ОЛЕ_Объект+".Application");
OLE.Documents.Add(""""+КаталогИБ()+"Шаблоны" + ФайлШаблон + """");
Для Индекс = 2 по сз.РазмерСписка() цикл
ТекстВывода = сз.ПолучитьЗначение(Индекс, Закладка);
//Если OLE.ActiveDocument.Bookmarks(СокрЛП(Закладка)).Exists()=0 Тогда // Проверяем - существует ли закладка
// Сообщить("Не найдена закладка "+Закладка,"!!!" ); Продолжить;
//КонецЕсли;
Попытка
OLE.ActiveDocument.Bookmarks(СокрЛП(Закладка)).Select(); //выделим выбранную закладку
OLE.Selection.TypeText(СокрЛП(ТекстВывода)); // выведем на место выделения текст
Исключение
Сообщить("Не найдена закладка "+Закладка,"!!!" );
КонецПопытки;
КонецЦикла;

OLE.Visible=1; /// видимость - True
OLE.ActiveDocument.Activate(); /// активизировать!!!
OLE=""; /// ссылочку прибить
КонецПроцедуры


Автор: GrayT
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 6310
 0 
Распечатать
Возможно, вас также заинтересует
Вывод несколько раз макета ActiveDocument в один документ Word 0
Текст кода для вывода шаблона несколько раз в один документ Ворд. Случилось, что понадобилось вывести шаблон справки к продукции для каждой строки ТЧ товары документа. Создаем макет печ. формы с типом ActiveDocument и...
Горячие клавиши 1С Разработчику [ Конфигуратор ] 20
Основные команды: Кодирование: Ctrl+Пробел - вызов подсказки Ctrl+Q - вызов шаблона Ctrl+F1 - поиск в синтакс-помощнике Ctrl + L - удалить текущую строку Alt+Shift+F - отформатировать код Исследование: F12 - ставим курсор на...
Замена текста в автофигуре word 0
Есть документ Word. Заполняю программно: TextFind.Execute(" " , Ложь, Истина, Ложь, , , Истина, , Ложь, " test" , 2); Текст находится в таблице, которая находится в автофигуре. Почему-то текст не заменяется, хотя вне.
Запрос по вхождению искомой строки в наименования элементов справочника 0
В данной статье я расскажу вам как быстро найти в справочнике элементы у которых в наименовании присутствует вхождение искомой нами строки: Текст запроса будет выглядеть так: Запрос = Новый Запрос; Запрос.Текст = ...
Использование регулярных выражений (RegExp) в 1С 1
Регулярные выражения (Regular Expressions) являются известным и мощным средством для поиска, тестирования и замены подстрок. Эта технология доступна и в 1С - через объект VBScript.RegExp. Нужный объект уже встроен в современные версии...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.