helpf.pro
Регистрация
 0 
Распечатать

Как проверить записан ли документ?

Перед обработкой документа необходимо проверить - записан ли документ? если Да - обработать, нет -вывести предупреждение!

Ниже код позволяющий проверить записан ли только что созданные документ:

В Такси и вообще управляемом приложении проверяется ссылка: Объект.Ссылка.Пустая()

Код 1C v 8.3
 // в Управляемом приложении
&НаКлиенте
Процедура ОбработатьДок(Отказ)
         Если не ЗначениеЗаполнено(Объект.Ссылка) тогда
            Отказ=Истина; //Докум еще не записан, т.к. ссылки нет         
    КонецЕсли;
КонецПроцедуры 
Код 1C v 8.х
 // В Обычных формах
Если ЭтоНовый() Тогда
Предупреждение("Документ должен быть записан!");
Иначе
// обрабатываем
КонецЕсли;

код, позволяющий проверить признак модифицированности ранее созданного документа:

Код 1C v 8.2 УП
 Если ЭтотОбъект.Модифицированность() Тогда
      
        Предупреждение("Документ был изменен. Для обработки его нужно записать.");
        Возврат Неопределено;     
      
    КонецЕсли;
Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 8086
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.