helpf.pro
Регистрация
 0 
Распечатать

Функция ЗначениеЗаполнено(Значение) для 8.0

В 8.1 есть такая встроенная функция, а в 8.0 про нее почему-то забыли, исправим это недоразумение:

Код 1C v 8.х
 
Функция ЗначениеЗаполнено(Значение) Экспорт
Результат = Истина;
ТипЗначения = ТипЗнч(Значение);

Если Значение = Неопределено Тогда
Результат = Ложь;
ИначеЕсли Значение = NULL Тогда
Результат = Ложь;
ИначеЕсли ТипЗначения = Тип( "Строка" ) Тогда
Если СокрЛП( Значение ) = "" Тогда
Результат = Ложь;
КонецЕсли;
ИначеЕсли ТипЗначения = Тип( "Число" ) Тогда
Если Значение = 0 Тогда
Результат = Ложь;
КонецЕсли;
ИначеЕсли ТипЗначения = Тип( "Дата" ) Тогда
Если Значение = Дата( '00010101' ) Тогда
Результат = Ложь;
КонецЕсли;
ИначеЕсли ТипЗначения = Тип( "Булево" ) Тогда
Результат = Истина;
ИначеЕсли ТипЗначения = Тип( "РежимПроведенияДокумента" ) Тогда
Результат = Истина;
Иначе
Если Значение = Новый( ТипЗначения ) Тогда
Результат = Ложь;
КонецЕсли;
КонецЕсли;
Возврат Результат;
КонецФункции

Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8023
 0 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.