helpf.pro
Регистрация
 0 
Распечатать

Вопрос/Сообщение пользователю. Интерфейс

Добрый день. Прошу помочь. надо вывести вопрос пользователю, при попытке изменить содержимое поля ввода. В синтакс-помощнике есть примерно такой вариант решения. Пробую при нажатии кнопки "отмена" или "нет"

все равно открывается справочник для выбора пользователя, нужно отменить это, а "Отказ", "Возврат" почему то не работают.........

Процедура ПолеВводаАвторНачалоВыбора(Элемент, СтандартнаяОбработка)

Режим = РежимДиалогаВопрос.ОКОтмена;

текст = "Сменить автора документа?";

ответ= вопрос (Текст, Режим, 0);

Если Ответ = КодВозвратаДиалога.Отмена Тогда

Отказ = Истина;

Возврат;

КонецЕсли;

КонецПроцедуры

Разместил:   Версии: | 8.x |  Дата:   Прочитано: 2570
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Авто добавление обработки в справочник Внешних обработок 0
Чтобы не изменять типовую конфигурацию приходится использовать типовой механизм внешних печатных форм и обработок. Данный код проверяет - добавлена ли открываемая обработка в конфигурацию, если нет - задает вопрос и...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.