helpf.pro
Регистрация
 0 
Распечатать

Как удалить дубли в списке значений

Если Вам необходимо почистить список значений от повторяющихся записей, используйте следующий код:

Код 1C v 8.х
 структошибок = Новый СписокЗначений;
//....
// заполнение списка значений
//....
//список значений в массив
Массив=структошибок.ВыгрузитьЗначения();
//Удаляем дубли из массива
ТекущийИндекс = 0; 
ВсегоЭлементов = Массив.Количество(); 
Пока ТекущийИндекс < ВсегоЭлементов Цикл 
Индекс2 = ТекущийИндекс + 1; 
Пока Индекс2 < ВсегоЭлементов Цикл 
Если Массив[Индекс2] = Массив[ТекущийИндекс] Тогда 
Массив.Удалить(Индекс2); 
ВсегоЭлементов = ВсегоЭлементов - 1; 
Иначе 
Индекс2 = Индекс2 + 1; 
КонецЕсли; 
КонецЦикла; 
ТекущийИндекс = ТекущийИндекс + 1; 
КонецЦикла; 

//Выведем результат
Для Каждого спстр из Массив цикл
Сообщить(спстр);
КонецЦикла;
Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 6249
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 10
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 4
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 5
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 1
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.