helpf.pro
Регистрация
 -1 
Распечатать

Функция расчет среднемесячного количества часов

Код 1C v 8.3
 
// Часто при создании дополнительных расчетов необходимо в расчете это получить
&НаСервере
Функция СреднемесячноеКоличествоЧасов(Год) 
    
    Запрос = Новый Запрос;


    Запрос.УстановитьПараметр("Год",Год);
    Запрос.УстановитьПараметр("РабочийДень", Перечисления.ВидыДнейПроизводственногоКалендаря.Рабочий);
    Запрос.УстановитьПараметр("ПредпраздничныйДень", Перечисления.ВидыДнейПроизводственногоКалендаря.Предпраздничный);


    Запрос.Текст =
    "ВЫБРАТЬ
    | СУММА(ВЫБОР
    |   КОГДА РегламентированныйПроизводственныйКалендарь.ВидДня =РабочийДень
    |    ТОГДА 1
    |   ИНАЧЕ 0
    |  КОНЕЦ) КАК ЧислоРабочихДней,
    | СУММА(ВЫБОР
    |   КОГДА РегламентированныйПроизводственныйКалендарь.ВидДня =ПредпраздничныйДень
    |    ТОГДА 1
    |   ИНАЧЕ 0
    |  КОНЕЦ) КАК ЧислоПредпраздничныхДней
    |ИЗ
    | РегистрСведений.ДанныеПроизводственногоКалендаря КАК РегламентированныйПроизводственныйКалендарь
    |ГДЕ
    | РегламентированныйПроизводственныйКалендарь.Год =Год";


    ВыборкаКалендаря = Запрос.Выполнить().Выбрать();
    Если ВыборкаКалендаря.Следующий() тогда
        ЧислоРабочихДнейВГоду = ?(ВыборкаКалендаря.ЧислоРабочихДней = NULL, 0, ВыборкаКалендаря.ЧислоРабочихДней); 
        ЧислоПредпраздничныхДнейВГоду = ?(ВыборкаКалендаря.ЧислоПредпраздничныхДней= NULL, 0, ВыборкаКалендаря.ЧислоПредпраздничныхДней);
    Иначе 
        ЧислоРабочихДнейВГоду = 0;
        ЧислоПредпраздничныхДнейВГоду = 0;
    КонецЕсли;
    
    СреднеМесячное = Окр((ЧислоРабочихДнейВГоду*8+ЧислоПредпраздничныхДнейВГоду*7)/12,2);


    Возврат СреднеМесячное;




КонецФункции
Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 949
 -1 
Распечатать
Возможно, вас также заинтересует
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Где находится файл лицензии 1С 17
Многие спрашивают А где хранится лицензия на 1С: Предприятие 8? или Где посмотреть лицензионный ключ в 1С? В 1С информацию о полученной лицензии можно посмотреть нажав «Справка» — «О программе» В разделе Лицензия:...
Где скачать классификатор ФИАС (вместо КЛАДР) для загрузки в 1С и как установить ФИАС? 2
Думаю, уже многие слышали что KLADR заменен на ФИАС (Федеральная информационная адресная система) Единой информацией из ФИАС будут обязаны пользоваться все ведомства – ГИБДД, Росреестр, ЗАГС, ФМС России и др, в...
Данные Графика регистра расчета 0
Виртуальная таблица " РегистрРасчета. ИмяРегистра .ДанныеГрафика " определена для тех регистров расчета, которые поддерживают период действия . При конфигурировании с таким регистром расчета необходимо связать...
Загрузка данных в 1С из PDF 3
В данной статье описан пример реализации загрузки данных накладных из PDF файлов для одного крупного Ритейла... И так у Нас есть несколько файлов в формате pdf, которые нам необходимо загрузить в 1С. Чтение PDF файлов из...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.