helpf.pro
Регистрация
 0 
Распечатать

Как сформировать, вывести на печать таблицу, табличный документ

Код 1C v 8.х
  //Получение макета и областей вывода
Макет = ПолучитьМакет("Отчет");
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьКартинки = Макет.ПолучитьОбласть("ОбластьСКартинкой")
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок = Новый ТабличныйДокумент;
//Вывод параметров в область
ОбластьЗаголовок.Параметры.ДатаНач = ДатаНач;
ОбластьЗаголовок.Параметры.ДатаКон = ДатаКон;
//Вывод области в табличный документ
ТабДок.Вывести(ОбластьЗаголовок);
//Вывод картинки
Картинка = Новый Картинка(ПутьККартинке);
// Элемент управления "Логотип" входит в коллекцию картинок области.
ОбластьКартинки.Рисунки.Логотип.Картинка = Картинка;
ТабДок.Вывести(ОбластьКартинки);
//Выведем шапку таблицы
ТабДок.Вывести(ОбластьШапкаТаблицы);
//Выведм строки из Результата запроса
ВыборкаДетали = Результат.Выбрать();
Пока ВыборкаДетали.Следующий() Цикл
//Заполним параметры значениями свойств переданного объекта. Заполняются только те параметры, имена которых совпадают с именами свойств объекта.
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
//Запишем в и область Описание примечание из запроса
ОбластьДетальныхЗаписей.Область("Описание").Примечание.Текст = ВыборкаДетали.СодержаниеСобытия;
ТабДок.Вывести(ОбластьДетальныхЗаписей);
КонецЦикла;
//Зададим параметры вывода
ТабДок.АвтоМасштаб=истина; // уместить на одну страницу
ТабДок.ТолькоПросмотр=истина;
ТабДок.ОриентацияСтраницы=ОриентацияСтраницы.Ландшафт;
ТабДок.ОтображатьСетку=Ложь;
ТабДок.ОтображатьЗаголовки=Ложь;
//Выведем полученный документ
ТабДок.Показать();


Код 1C v 7.x
  
Процедура ПросмотрДокумента()
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("РасходныйДокумент");
Секция = Таб.ПолучитьСекцию("Шапка");
Таб.ВывестиСекцию(Секция);
Секция = Таб.ПолучитьСекцию("ПодписьТаблицы");
Таб.ВывестиСекцию(Секция);
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Секция = Таб.ПолучитьСекцию("ТабличнаяЧасть");
Таб.ВывестиСекцию(Секция);
КонецЦикла;
Секция = Таб.ПолучитьСекцию("Подвал");
Таб.ВывестиСекцию(Секция);
Таб.ТолькоПросмотр(0);
Таб.Показать();
КонецПроцедуры
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 22537
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.