helpf.pro
Регистрация
 0 
Распечатать

Запись движений в оборотный регистр

Методы доступны только при проведении документа в предопределенной процедуре ОбработкаПроведения.
Метод Движение - Выполнить запись движения в оборотный регистр по параметрам.
Код 1C v 7.x
 
Регистр.Товары.Движение (ПоступившийТовар, ТекСклад, КолвоПоНакладной, СуммаПоНакладной)

Код 1C v 7.x
 
Процедура ОбработкаПроведения();
ВыбратьСтроки();
Пока ПолучитьСтроку() > 0 Цикл
Регистр.ОборотыТоваров.Движение(Товар, Склад, ОборотТовара);
КонецЦикла;
КонецПроцедуры


Метод ДвижениеВыполнить - Выполнить запись движения в оборотный регистр по атрибутам.
Код 1C v 7.x
  Процедура ОбработкаПроведения();
Регистр.ТовЗап.Склад = Склад;
ВыбратьСтроки();
Пока (ПолучитьСтроку() > 0) Цикл
Регистр.ТовЗап.Товар = Товар;
Регистр.ТовЗап.Оборот = Оборот;
Регистр.ТовЗап.ДвижениеВыполнить();
КонецЦикла;
КонецПроцедуры;


Примечание: Если сумма или количество в движении будет отрицательным, то это движение будет расходом, иначе приходом.
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 6382
 0 
Распечатать
Возможно, вас также заинтересует
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Автоматическая выгрузка загрузка данных используя регламентное задание 1
Для обмена данными между программами необходимо сделать следующее: 1. При помощи Конвертации Данных создать правила выгрузки данных 2. Нужно чтобы в конфигурации была обработка УниверсальныйОбменДаннымиXML ,...
Архивирование файлов средствами 1C (ZIP) 0
ИмяZIPФайла = ПолучитьИмяВременногоФайла(" .zip" ); ФайлАрхива = Новый ЗаписьZipФайла(ИмяZIPФайла, , , МетодСжатияZIP.Сжатие, УровеньСжатияZIP.Оптимальный); ФайлАрхива.Добавить(ИмяВременногоФайла, ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.