helpf.pro
Регистрация
 +1 
Распечатать

Функции Шаблон и ФиксШаблон

Шаблон
Функции возвращают строковое значение, сформированное в соответствии с заданным параметром <Строка_шаблон>, заменив в ней все встро­енные выражения, заключенные в квадратные скобки, на их строковые значе­ния.
Строковое значение параметра <Строка_шаблон> обрабатывается сле­дующим образом: символы "[" , "]" (квадратные скобки) являются специаль­ными символами, которые выделяют поля, содержащие встроенные выражения. Выделенные поля фиксируют свою длину с учетом ограничивающих скобок. Например:
Имя Клиента [Имя], телефон: [Телефон]

После встроенного выражения может стоять символ "#", после которого следует Форматная_строка описанная в функции Формат. В этом случае в данное поле будет проставлен результат выражения, обработанный функцией Формат.

Код 1C v 7.x
 
Стр = Шаблон("Это название услуги: [Услуга.Наименование]");
// выдает: "Это название услуги: Доставка Товара"



ФиксШаблон

В отличие от функции Шаблон, поля замещаются значениями выражений с со­хранением своей длины в символах, то есть обрезаются, если поле короче ре­зультата вычисления выражения и дополняются пробелами если длиннее. Если результат числовой, то в границах поля строка прижимается к правой границе.

Код 1C v 7.x
 
// ниже - пример с дополнением пробелами
Стр = ФиксШаблон("Это название услуги [Услуга.Наименование]");
// выдает: "Это название услуги Доставка Товара"
// далее - с сокращением строки
Стр = ФиксШаблон("Это название услуги [Услуга.Наименование]");
// выдает: "Это название услуги Упаковка товара"


Примеры вспомогательных функций для вычисления выражений с помощью системной функции Шаблон():
Код 1C v 7.x
 
// Возвращает объект любого типа. По сути является универсальной, но
// работает дольше чем _Вычислить(), поэтому рекомендовал бы
// использовать ее когда нужно вернуть именно объект
Функция _ВычислитьОбъект( Выражение ) Экспорт
Возврат ЗначениеИзСтроки(Шаблон( "[ЗначениеВСтроку("+ Выражение+")]"));
КонецФункции

// Возвращает число. Использую ее когда нужно получить результат выполнения
// лок. функции, которые обычно возвращают 0/1 или когда просто нужно вызвать
// лок. функцию из глоб. модуля
Функция _Вычислить( Выражение) Экспорт
Возврат Число(Шаблон( "["+ Выражение+ "]"));
КонецФункции
Вызов функции осуществляется так:
_Вычислить( "ИмяЛокФункции()");

// Возвращает строку. Функцию удобно использовать когда нужно получить значение
// лок. переменной в гл. модуле
Функция _ВычислитьСтроку( Выражение) Экспорт
Возврат Строка(Шаблон( "["+ Выражение+ "]"));
КонецФункции
Вызов функции осуществляется так:
глПерем= _ВычислитьСтроку( "ЛокПерем");

// Присвоение. Функция используется для присвоения значений локальным переменным из гл. модуля
Функция _Присвоение ( Приемник ,Источник) Экспорт
Попытка
Приемник = Источник ;
Исключение
КонецПопытки;
КонецФункции
Функция вызывается примерно так:
_Вычислить ("_Присвоение(ЛокПерем,глПерем)" );
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 7472
 +1 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.