helpf.pro
Регистрация
 +1 
Распечатать

Открытие периода оперативных итогов

Код 1C v 7.x
 // Открытие периода
ДатаТА = ПолучитьДатуТА();
Если (РабочаяДата() > ДатаТА) И ((ДатаМесяц(ДатаТА) <> ДатаМесяц(РабочаяДата())) ИЛИ (ДатаГод(ДатаТА) <> ДатаГод(РабочаяДата()))) Тогда
Если МонопольныйРежим() = 0 Тогда
Ответ=Вопрос("Не открыт период!" + РазделительСтрок + "Для открытия периода запустите программу в монопольном режиме!" + РазделительСтрок + "Завершить работу программы?","Да+Нет");
Если Ответ="Да" Тогда
СтатусВозврата(0);
Возврат;
КонецЕсли;
Иначе // монопольный режим
Ответ=Вопрос("Не открыт период!"+ РазделительСтрок +"Выполнить открытие& ;периода?","Да+Нет");
Если Ответ="Да" Тогда
УстановитьТАНа(РабочаяДата());
КонецЕсли;
КонецЕсли;
КонецЕсли;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 6844
 +1 
Распечатать
Возможно, вас также заинтересует
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Вывод результата запроса в табличный документ 0
//Вых - ЭлементыФормы.РезультатТабличныйДокумент, //ТЗЗ - Результат выполнения запроса Процедура ПечатьРезвТаб(Вых,ТЗЗ) Экспорт КоличествоКолонок = ТЗЗ.Колонки.Количество(); Выборка =...
Выгрузка данных в Excel с установкой разных параметров 4
// Процедура выгружает из указанного справочника данные в режиме экспорта в файл в формате Microsoft Excel // с указанным именем, используя преобразование данных к типу число и типу строка; Процедура...
Географическая схема - что это? 0
Географическая схема позволяет наглядно представить итоговые данные в разрезе их географического положения. Это позволяет создавать отчеты иллюстрирующие, например, объемы продаж тех или иных товаров в различных...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.