helpf.pro
Регистрация
 0 
Распечатать

Построение диаграммы

Код 1C v 8.х
 Процедура ФормДиаграммы()
Траб=Новый ТаблицаЗначений;
Траб.Очистить();
Траб.Колонки.Добавить("ххх");
Траб.Колонки.Добавить("Норм");
Траб.Колонки.Добавить("Факт");

НовСтр=Траб.Добавить();
НовСтр.ххх="а1";
НовСтр.Норм=5;
НовСтр.Факт=10;
НовСтр=Траб.Добавить();
НовСтр.ххх="а2";
НовСтр.Норм=2;
НовСтр.Факт=15;
НовСтр=Траб.Добавить();
НовСтр.ххх="а3";
НовСтр.Норм=8;
НовСтр.Факт=14;

ТабДок = Новый ТабличныйДокумент;
Макет = Отчеты.УчетнаяКарточка.ПолучитьМакет("Диагр");

ОблДиаграмма = Макет.ПолучитьОбласть("Диагр1");
Диаграмма = ОблДиаграмма.Рисунки.D1.Объект;

Диаграмма.СерииВСтроках = Ложь;
Диаграмма.Обновление=Ложь;

Диаграмма.ИсточникДанных = Траб;

Диаграмма.Обновление=Истина;
ТабДок.Вывести(ОблДиаграмма);

ТабДок.АвтоМасштаб=Истина;
ТабДок.ОриентацияСтраницы=ОриентацияСтраницы.Ландшафт;
ТабДок.Показать();
КонецПроцедуры


Полезная процедура формирования диаграммы в макете

Строить можно и в макете и в форме.
Код 1C v 8.х
 
Процедура ПостроитьДиаграмму(Траб,Диаграмма)

Для Каждого Колонка из Траб.Колонки Цикл
Если Траб.Колонки.Индекс(Колонка) <> 0 Тогда
Диаграмма.Серии.Добавить(Колонка.Имя);
КонецЕсли;
КонецЦикла;

Для Каждого СтрТраб из Траб Цикл
Точка=Диаграмма.Точки.Добавить(СтрТраб.Получить(0));
Индекс=0;
Для Каждого Серия из Диаграмма.Серии Цикл
Индекс=Индекс+1;
Диаграмма.УстановитьЗначение(Точка,Серия,СтрТраб.Получить(Индекс));
КонецЦикла;
КонецЦикла;
КонецПроцедуры

gwa. Григорьев В.
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 10493
 0 
Распечатать
Возможно, вас также заинтересует
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Вывод Диаграммы График Валют, Сохранение диаграммы, графиков и гистограмм в виде Картинки 0
Алгоритм обработки выполняет запрос к регистру сведений " курсы валют" за определенный пользователем период. Полученные данные выборки в цикле выводятся в элемент экранной формы " диаграмма" в режиме построения...
Вывод отчета СКД в коллекцию значений - Дерево Значений 1
В системе компоновки данных существует возможность выводить отчет не только в табличный документ, но и в коллекции значений (таблица значений, дерево значений). Для вывода отчета в коллекцию предназначен объект ...
Добавление поддержки нестандартного штрих-кода в обработке ПечатьЭтикеток 0
Обработка ПечатьЭтикеток использует компоненту " 1С:Печать штрихкодов" (доступную на диске ИТС) для печати штрих-кодов(далее ШК). Эта компонента поддерживает следующие типы штрих-кодов: EAN8, EAN13, EAN128, Code39, Code128. Что делать...
Заполним диаграмму Ганта данными 0
ДГ = ЭлементыФормы.ДГ; // Установить заголовок диаграммы. ДГ.ОбластьЗаголовка.Текст = " График дежурств" ; // Интервал будем определять самостоятельно. ДГ.АвтоОпределениеПолногоИнтервала = Ложь; // Установить...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.