helpf.pro
Регистрация
 0 
Распечатать

Поиск в DBF файле по индексу

Код 1C v 7.x
  ДБФ=СоздатьОбъект("XBase");
ДБФ.ДобавитьПоле("DATE","D",0,0);
Дбф.ДобавитьИндекс("INDEX","DTOS(DATE)",0,0,"<");
//Дбф.ДобавитьИндекс("INDEX","DTOS(DATE)",0,0,"Пустая строка"); //DTOS !!!
// где DTOC() - "ММ/ДД/ГГ" или DTOS() - "ГГГГММДД"
ДБФ.СоздатьФайл("c:\test.dbf","c:\test.cdx");
Для ТекДата='01.09.05' По '10.09.05' Цикл
Дбф.Добавить();
Дбф.DATE=ТекДата;
ДБФ.Записать();
КонецЦикла;
//ДБФ.КодоваяСтраница(0);
ДБФ.ТекущийИндекс("INDEX");
Для ТекДата='01.09.05' По '10.09.05' Цикл
ДБФ.Ключ.DATE = ТекДата;
Если ДБФ.НайтиПоКлючу(0)=1 Тогда
Сообщить(ТекДата);
КонецЕсли;
КонецЦикла;
ДБФ.ЗакрытьФайл();
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 7394
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
Быстрый перенос списка баз с одного компьютера на другой 0
Для 8.1 : 1. Список баз 8.1 можно сохранять в файл.Для этого правой кнопкой мыши по корневому элементу " Информационные базы " , далее " Сохранить ссылку в файл " . 2. Получаем файл с расширением v8i , это текстовый файл в...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.