helpf.pro
Регистрация
 0 
Распечатать

Расчет начислений по сотруднику, подразделени, документу

Код 1C v 7.x
 //   Посчитаем все начисления текущего сотрудника за январь:
ВсегоНачислено = 0;
ЖЗ.ВыбратьЗаписиПоОбъекту (ТекСотр, ДатаНач, ДатаКон);
Пока ЖЗ.ПолучитьЗапись()=1 Цикл
Если ЖЗ.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеНачисления)=1 Тогда
ВсегоНачислено = ВсегоНачислено + ЖЗ.Результат;
КонецЕсли;
КонецЦикла;

// Теперь рассчитаем все записи текущего сотрудника, введеные в текущем месяце:
ЖЗ.ВыбратьПериодПоОбъекту (ТекСотр, ДатаНач);
Пока ЖЗ.ПолучитьЗапись()=1 Цикл
ЖЗ.Рассчитать();
КонецЦикла;

/// Рассчитаем все записи по документу, независимо от того, в каком расчетном периоде записи порождались:
ЖЗ.ВыбратьЗаписиПоДокументу (ВыбрДокумент);
Пока ЖЗ.ПолучитьЗапись()=1 Цикл
ЖЗ.Рассчитать();
КонецЦикла;

// Рассчитаем все записи по указанному подразделению. В журнале расчетов указана графа отбора "Подразделение".
ТекПер = ЖЗ.ТекущийПериод();
ЖЗ.ВыбратьПоЗначению ("Подразделение",ВыбрПодразделение, ТекПер, ТекПер);
Пока ЖЗ.ПолучитьЗапись()=1 Цикл
ЖЗ.Рассчитать();
КонецЦикла;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 4464
 0 
Распечатать
Возможно, вас также заинтересует
Ввод договоров ГПХ в ЗУП (счет 76) 5
Часто меня спрашивают: Как правильно отразить договор ГПХ в ЗУП? Ниже небольшая, последовательная инструкция: Прием на работу Сведения о физическом лице, выполняющем работы по договору подряда, должны быть внесены...
Выборка запросом, перебор задач 0
Выбрать( Отбор , Порядок ) Отбор (необязательный) - Структура. Задает реквизит вида расчета и значение этого реквизита, по которому будет создана выборка. Ключ структуры задает имя реквизита, а значение структуры -...
Выбрать все движения регистра по документу 0
Процедура Взаиморасчеты(ВыбКлиент, ДатаНачало, ДатаКонец) // Создание Таблицы для выходного отчета Заг = " Неизвестно." ; Таб = СоздатьОбъект(" Таблица" ); Клн = СоздатьОбъект(" Справочник.Клиенты" ); ...
ДБФ, работа с Индекс, Ключ 0
ФайлНаДиске = Новый Файл(ИмяФайла); Если НЕ(ФайлНаДиске.Существует()) Тогда Предупреждение(" Файл с таким именем не существует " + ИмяФайла); Возврат; КонецЕсли; ДБФ = Новый xBase; ДБФ.Кодировка = КодировкаXBase.OEM; ...
Добавление в набор сторно-записей 0
Если в рассчитываемом регистре установлено свойство Период действия, в сформированном наборе могут присутствовать записи, у которых период действия принадлежит более раннему периоду, чем период регистрации. В этом...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.