helpf.pro
Регистрация
 0 
Распечатать

Как отобразить на географической схеме выбранный город?

Код 1C v 8.х
 Схема = ЭлементыФормы.ГеоСхема; 
СписокГородов = Новый СписокЗначений;

// Запретить перерисовку схемы на время обновления.
Схема.Обновление = Ложь;

// Отобразить слой Регионы.
Схема.Слои.Регионы.Видимость = Истина;

// Задать тип отображения названий городов.
СлойГорода = Схема.Слои.Города;
СлойГорода.Серии.Название.ТипОтображения = ТипОтображенияСерииСлояГеографическойСхемы.Текст;

// Сформировать список городов и скрыть все города.
Для Счетчик = 0 По СлойГорода.Объекты.Количество() - 1 Цикл
Город = СлойГорода.Объекты.Получить(Счетчик);
Город.Видимость = Ложь;
НазваниеГорода = СлойГорода.ПолучитьЗначение(Город, СлойГорода.Серии.Название);
НазваниеРегиона = СлойГорода.ПолучитьЗначение(Город, СлойГорода.Серии.Регион);
СписокГородов.Добавить(Счетчик, НазваниеГорода.Значение + " (" + НазваниеРегиона.Значение + ")");
КонецЦикла;

СлойГорода.Видимость = Истина; // Отобразить слой Города.

СписокГородов.СортироватьПоПредставлению();
ВыбранныйГород = СписокГородов.ВыбратьЭлемент();
Если ВыбранныйГород <> Неопределено Тогда
ГородСхемы = СлойГорода.Объекты.Получить(ВыбранныйГород.Значение);
ГородСхемы.Видимость = Истина; // отобразить выбранный город
КонецЕсли;

Схема.Обновление = Истина; // Обновить схему.
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 7174
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
Ввод данных по командировкам в программе ЗУП 0
Ввод сведений о командировках в программе 1С: Зарплата и управление персоналом 8 (ред.30) осуществляется в Разделе Кадры - Все кадровые документы - Создать - Командировка Откроется документ: Ввод сведений о...
Выбор ~ Как открыть пользователю стандартный диалог выбора Цвета или Шрифта? 0
Диалог = Новый ДиалогВыбораЦвета; Если Диалог.Выбрать() Тогда ВыбранныйЦвет = Диалог.Цвет; КонецЕсли; Диалог = Новый ДиалогВыбораШрифта; Если Диалог.Выбрать() Тогда ВыбранныйШрифт = Диалог.Шрифт; КонецЕсли;
Выбор периода, задать период 2

Загрузка данных из XML файла в Таблицу Значений и вывод в Табличный документ 0
Перем ИмяПути,ИмяФайла; Перем xmlParser; //пример чтения xml файла. Функция УстановитьКомпоненту() Если ЗагрузитьВнешнююКомпоненту(КаталогИБ()+" ExtFormsv7plus.dll" )=0 Тогда Если ЗагрузитьВнешнююКомпоненту(" v7plus.dll" )=0 Тогда ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.