helpf.pro
Регистрация
 0 
Распечатать

Поиск из 1С в Excel

Для 8.х в нижеследующем коде замените СоздатьОбъект( на Новый COMОбъект!

Код 1C v 7.x
 //Пример 1:
Процедура Сформировать()
Екскел=СоздатьОбъект("Excel.Application");
Книга=Екскел.WorkBooks.Open("C:\Ищем.xls");
Книга.Worksheets(1).Unprotect ("1qaz");
Для к=1 По Книга.Worksheets.Count Цикл
Диапазон = Книга.Worksheets(к).UsedRange;
Попытка
Найдено = Диапазон.Find("цу");
Истина=-1;
Исключение
Истина=0;
КонецПопытки;
Если Истина=-1 Тогда
АдресПреж = Найдено.Address;
Пока Истина=-1 Цикл
Сообщить(""+Книга.Worksheets(к).Name+"; "+Найдено.Address);
Попытка
Найдено = Диапазон.FindNext(Найдено);
Истина=-1;
Исключение
Истина=0;
КонецПопытки;
Истина=?((Истина=-1) И (Найдено.Address <> АдресПреж),-1,0);
КонецЦикла;
КонецЕсли;
КонецЦикла;
Сообщить(Книга.Worksheets(1).Cells(1, 1).Text);
КонецПроцедуры


//Пример 2:
Процедура НайтиСтроку(Application,СтрокаПоиска)
S_election=Application.S_election;
Скрипт=СоздатьОбъект("MSScriptControl.ScriptControl");
Скрипт.Language="vbscript";
Скрипт.AddObject("S_election",S_election);
Скрипт.AddObject("ActiveCell",Application.ActiveCell);
//res=Скрипт.Eval("S_election.Find("+СтрокаПоиска+",ActiveCell,-4163,1).activate()");

res=Скрипт.Eval("S_election.Find("+СтрокаПоиска+",ActiveCell,-4163,1)");
Сообщить("результат "+res.Address);
КонецПроцедуры

Процедура Сформировать()
Путь="C:\test.xls";
Str="567";
Попытка
Application=СоздатьОбъект("Excel.Application");
Исключение
Сообщить(ОписаниеОшибки(),"!!!");
Сообщить("Возможно, MS Excel не установлен на этом компьютере.");
Возврат;
КонецПопытки;
НайтиСтроку(Application,Str);
КонецПроцедуры
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 14387
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.