helpf.pro
Регистрация
 0 
Распечатать

Как начать транзакцию в режиме управляемых транзакционных блокировок?

У метода системы НачатьТранзакцию() есть параметр, с помощью которого можно указать режим управления.
Код 1C v 8.х
 // Указание режима открываемой транзакции
// Транзакция предназначена для записи в информационную базу согласованных изменений.
// Все изменения, внесенные в информационную базу после начала транзакции,
// бу­дут затем либо целиком записаны, либо целиком отменены.
НачатьТранзакцию(РежимУправленияБлокировкойДанных.Управляемый);

// Код, исполняемый в рамках транзакции.
// ...

Если ОбнаруженыОшибки Тогда
// Отменяем открытую ранее транзакцию.
// Все изменения, внесенные в информационную базу в процессе транзакции, будут отменены.
ОтменитьТранзакцию();
КонецЕсли;

// Завершаем успешную транзакцию.
// Все изменения, внесенные в информационную базу в процессе транзакции, будут записаны.
ЗафиксироватьТранзакцию();

Следует помнить, что «вложенных» транзакций в системе 1С:Предприятие 8 нет. Также надо иметь в виду, что параметр «действует» только в том случае, если в свойстве конфигурации Режим управления блокировкой данных выбрано значение Автоматический и управляемый. Если для конфигурации установлен режим Автоматический, то все транзакции будут исполняться в автоматическом режиме; если Управляемый, то в управляемом режиме.

Пример:
Код 1C v 8.х
 // Увеличение закупочной цены на 5%
ВыборкаТоваров = Справочники.Номенклатура.Выбрать();
НачатьТранзакцию();
Пока ВыборкаТоваров.Следующий() Цикл
ТоварОбъект = ВыборкаТоваров.ПолучитьОбъект();
ЗакупочнаяЦена = ТоварОбъект.ЗакупочнаяЦена;
Если ЗакупочнаяЦена <> 0 Тогда
ТоварОбъект.ЗакупочнаяЦена = ЗакупочнаяЦена * 1.05;
ТоварОбъект.Записать();
КонецЕсли;
КонецЦикла;
ЗафиксироватьТранзакцию();
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 9657
 0 
Распечатать
Возможно, вас также заинтересует
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.