helpf.pro
Регистрация
 0 
Распечатать

Как открыть *.DOC файл из хранилища значений для редактирования?

Код 1C v 8.х
  Процедура КнопкаDOCНажатие(Элемент)

ИмяФайла = ПолучитьИмяВременногоФайла("doc");
Doc = ХранилищеФайла.Получить();

Если Doc <> Неопределено Тогда

Doc.Записать(ИмяФайла)
Word = Новый COMОбъект("Word.Application");
Word.Documents.Open(ИмяФайла);
Word.Visible = Истина;

ДобавитьОбработчик Word.DocumentBeforeClose, ПередЗакрытиемДокументаWord;
ДобавитьОбработчик Word.Quit, ВыходИзWord;

КонецЕсли;

КонецПроцедуры

//Процедуры назначаемые обработчиками
Процедура ПередЗакрытиемДокументаWord(Документ, Отмена)
Документ.Save();
КонецПроцедуры

Процедура ВыходИзWord()
ШаблонДоговора = Новый ХранилищеЗначения(Новый ДвоичныеДанные(ИмяФайла));
КонецПроцедуры



Тема обсуждения
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7748
 0 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.