helpf.pro
Регистрация
 +1 
Распечатать

Как вывести всплывающее сообщение пользователю?

В 8.2 нужно воспользоваться функцией ПоказатьОповещениеПользователя
Код 1C v 8.2 УП
 ПоказатьОповещениеПользователя("Документ не записан!", 
"http://doc.ru",
"О правилах заполнения документа, читайте здесь!",
БиблиотекаКартинок.Важно);


Код 1C v 8.х
 #Если Клиент Тогда
Форма = Источник.ПолучитьФорму();
Если Форма.Открыта() Тогда
ПоказатьОповещениеПользователя("Ошибка", ПолучитьНавигационнуюСсылку(Источник.Ссылка), "Не указана организация. Невозможно распределить платежи по документам расчетов с контрагентом", БиблиотекаКартинок.Ошибка32);
КонецЕсли;
#КонецЕсли



В 7.7 и 8.1 всплывающие окна отсутствуют, но это легко решается использованием:
Код 1C v 7.x
 WshShell=СоздатьОбъект("WScript.Shell");
WshShell.Popup("Текст сообщения",,"Текст заголовка",20);

или внешних компанент, например:
MiracleV8: Универсальная компонента для 1С 7.7 и 1С 8.x
[Tray1C] Сворачивание 1С в системный трей


Вывод иконки с восклицательным знаком в трей! Используя AutoHotkey:
Код 1C v 8.х
  //Процедура выводит или убирает сообщение мессенджера и иконку, в зависимости от бПарам
Процедура ВывестиСообщениеМессенджера(бПарам = Истина) Экспорт
#Если Клиент Тогда

сКаталог = СокрЛП(Константы.КаталогПолногоДоступа.Получить())+"БП\MessageService";
ИмяФайла = сКаталог + "\autohotkey.exe";
Файл = Новый Файл(ИмяФайла);

ИмяФайлаИНИ = сКаталог + "\autohotkey.ini";

Если бПарам Тогда
ИмяФайлаИНИ_Задачи = сКаталог + "\autohotkey_Yes.ini";
Иначе
ИмяФайлаИНИ_Задачи = сКаталог + "\autohotkey_No.ini";
КонецЕсли;

ФайлИНИ_Задачи = Новый Файл(ИмяФайлаИНИ_Задачи);

Если Файл.Существует() И ФайлИНИ_Задачи.Существует() Тогда

Попытка
КопироватьФайл(ИмяФайлаИНИ_Задачи,ИмяФайлаИНИ);
ЗапуститьПриложение(ИмяФайла, сКаталог);
Если бПарам Тогда
ПараметрыСеанса.бСостояниеМессенджера = Истина;
Иначе
ПараметрыСеанса.бСостояниеМессенджера = Ложь;
КонецЕсли;
Исключение

КонецПопытки;

КонецЕсли;
#КонецЕсли
КонецПроцедуры
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 22163
 +1 
Распечатать
Возможно, вас также заинтересует
Как поменять период у записей периодического независимого регистра, соответствующих ряду условий? 0
В периодическом независимом регистре сведений ОтветственныеЛицаОрганизации все записи, касающиеся организации с наименованием Групп-трейдинг, период которых меньше 01 января 2005 года, необходимо перенести на 01...
Полезные возможности редактора кода 1С 6
Мне частенько приходится взаимодействовать с 1С-разработчиками, и во время совместной работы над проектами замечаю, что далеко не все из них хорошо знают свой главный инструмент – «Конфигуратор». Причем это не...
Разрешить разделение итогов - что это? 0
Это механизм который обеспечивает параллельность работы (имеется ввиду увеличение производительности при параллельной работе нескольких задач с одним регистром). Механизм реализован для регистров накопления и...
Тормозит сервер 1С или компьютер с 1С - Настройка и Оптимизация 5
Очень часто ко мне обращаются с вопросами вида: из-за чего тормозит сервер 1С? компьютер с 1С работает очень медленно жутко тормозит клиент 1С Что же делать и как это победить, и так по порядку: Клиенты очень...
Универсальная функция для чтения данных из Excel в 1С 1
Иногда требуется разобрать данные из Excel в 1С. Я считаю что легче и быстрей поместить все данные в ТаблицуЗначений и уже там ими манипулировать. Пример 2-х функций которые я использую: ИзExcelВТаблицу – Читает Excel в...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.