helpf.pro
Регистрация
FAQ 1С 7.x » Категорий: 40
Найти...

Все версии7.x8.x ОП8.2 УП8.3 УПВидео   Добавить FAQ
1С Бухгалтерия 2.0 » 5Отчеты » 2
1С Зарплата и Управление Персоналом 2.5 » 4Перечисления » 1
1С Общие вопросы - Обычные формы » 23Полезные, Универсальные Функции » 28
1С Управление торговлей 10.3 » 1Пользователь, роль доступа, интерфейс » 4
COM-объекты, WMI, WSH » 24Работа с Microsoft Office и OpenOffice » 30
HTML, JS, VML » 4Работа с Датами (Временем) » 13
OLE, ActiveX » 2Работа с Интернет, Почтой (Mail), FTP » 4
XML, DBF, TXT, CSV » 7Работа с Таблицей Значений » 1
Администрирование » 52Работа с Текстом (Строкой) » 7
Виды расчетов » 6Работа с Типами данных » 1
Виды Субконто » 2Работа с Файлами и Каталогами » 6
Внешние компоненты » 2Работа с Формой (Диалог) и её элементами » 1
Встроенные Функции » 20Работа с Числами » 9
Группы расчетов » 1Регистры » 30
Диаграмма » 1Регулярные выражения » 11
Документы » 5Системные Ошибки » 4
Журналы расчетов » 14Список Справочника, Документов, Регистров » 1
Конвертация данных, Обмен, Перенос » 2Справочники » 18
Метаданные » 7Табличный документ » 6
Операция » 2Штрих-код (barcode) » 2
Категория: Журналы расчетов
Версии: 7.x

жз = СоздатьОбъект(" ЖурналРасчетов.Зарплата" ); пер = жз.ТекущийПериод(); Сообщить(" Текущий период:" + Символ Табуляции + пер); пер = пер.ПрибавитьПериод(1); Сообщить(" Период после:" + СимволТабуляции + пер); пер = пер.ПрибавитьПериод(-2);
Подробнее  Разместил: E_Migachev  Дата: 20.05.2010  Прочитано: 9040  Комментарии
0 
Распечатать
Категория: Администрирование
Версии: 7.x 8.x 8.2 УП

Если такое происходит, обратите внимание на следующее: Посмотрите, какой режим восстановления ( Recovery ) стоит на закладке Options в свойствах базы данных. Он бывает Simple (простой, который требует наименьшего администрирования) или Full
Подробнее  Разместил: E_Migachev  Дата: 26.04.2010  Прочитано: 51896  Комментарии
0 
Распечатать
Категория: COM-объекты, WMI, WSH
Версии: 7.x

// maharbA Функция Hex(Пар) Результат=" " ; Пока Пар 0 Цикл Результат=Сред(" 0123456789ABCDEF" ,Пар+1,1)+Результат; Пар=Цел(Пар/16) ; КонецЦикла; Возврат " " +Результат; КонецФункции Функция ПолучитьПринтерПоУмолчанию() ПринтерПоУмолчанию
Подробнее  Разместил: E_Migachev  Дата: 26.04.2010  Прочитано: 14414  Комментарии
0 
Распечатать
Категория: Метаданные
Версии: 7.x

// Пример 1 Для к = 1 по Метаданные.РеквизитПроводки() Сообщить(Метаданные.РеквизитПроводки(к).Идентификатор); КонецЦикла; // Пример 2 СписокРеквизитов = СоздатьОбъект(" СписокЗначений" ); // реквизиты формы операции СписокРеквизитов.
Подробнее  Разместил: E_Migachev  Дата: 20.04.2010  Прочитано: 11999  Комментарии
0 
Распечатать
Категория: Работа с Числами
Версии: 7.x 8.x 8.2 УП

Встроенные функции 1С 8.х для работы со значениями типа Число: // Функция вычислет степень числа // _База - Число - Число, возводимое в степень // _Степ - Число - Степень числа Функция Степень(_База, _Степ) Р
Подробнее  Разместил: E_Migachev  Дата: 20.04.2010  Прочитано: 22794  Комментарии
0 
Распечатать
Категория: Работа с Числами
Версии: 7.x 8.x

В 1С 8.х есть встроенная функция: sqrt(аргумент); Возвращает квадратный корень аргумента. * аргумент: число //Вычислить квадратный корень числа. Результат = sqrt(169); //Результат = 13 А если вспомнить школьную математику *04 Корень квадра
Подробнее  Разместил: E_Migachev  Дата: 20.04.2010  Прочитано: 23967  Комментарии
0 
Распечатать
Категория: Табличный документ
Версии: 7.x 8.x

//Фиксируем область, Закрепим область, сверху 4 ячейки, слева 1 ТаблДокумент.ФиксацияСверху = 4; ТаблДокумент.ФиксацияСлева = 1; //Установить вид страницы Альбомная ТаблДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт; //Установим ав
Подробнее  Разместил: E_Migachev  Дата: 19.04.2010  Прочитано: 63910  Комментарий: 1
+4 
Распечатать
Категория: Работа с Датами (Временем)
Версии: 7.x 8.x 8.2 УП

В Платформе 8.2.17 реализована возможность получения числа миллисекунд, прошедших с 1 января 0001 года, 0:00:00 UTC с помощью функции ТекущаяУниверсальнаяДатаВМиллисекундах() // В 8.х переменные типа " дата" содержат миллисекунды, только это н
Подробнее  Разместил: E_Migachev  Дата: 19.04.2010  Прочитано: 55693  Комментарии: 2
0 
Распечатать
Категория: Отчеты
Версии: 7.x

//Открыть отчет в новом окне можно, для этого надо добавить решетку: РасположениеФайла(Путь,Файл); ОткрытьФорму(" Отчет#" , Параметр,Путь+Файл);
Подробнее  Разместил: E_Migachev  Дата: 19.04.2010  Прочитано: 10246  Комментарии
+1 
Распечатать
Категория: Отчеты
Версии: 7.x 8.x

В 8-ых версиях используйте: ИспользуемоеИмяФайла (UsedFileName) Использование: Только чтение. Описание: Тип: Строка. Содержит полное имя файла внешней обработки. Недоступно на сервере 1С:Предприятие. Не используется в модуле внешнего соедине
Подробнее  Разместил: E_Migachev  Дата: 19.04.2010  Прочитано: 34625  Комментарии
+4 
Распечатать
Всего 365 на 37 страницах по 10 на каждой странице