helpf.pro
Регистрация
FAQ 1С 7.x » Категорий: 40
Найти...

Все версии7.x8.x ОП8.2 УП8.3 УПВидео   Добавить FAQ
1С Бухгалтерия 2.0 » 5Отчеты » 2
1С Зарплата и Управление Персоналом 2.5 » 4Перечисления » 1
1С Общие вопросы - Обычные формы » 23Полезные, Универсальные Функции » 28
1С Управление торговлей 10.3 » 1Пользователь, роль доступа, интерфейс » 4
COM-объекты, WMI, WSH » 24Работа с Microsoft Office и OpenOffice » 30
HTML, JS, VML » 4Работа с Датами (Временем) » 13
OLE, ActiveX » 2Работа с Интернет, Почтой (Mail), FTP » 4
XML, DBF, TXT, CSV » 7Работа с Таблицей Значений » 1
Администрирование » 52Работа с Текстом (Строкой) » 7
Виды расчетов » 6Работа с Типами данных » 1
Виды Субконто » 2Работа с Файлами и Каталогами » 6
Внешние компоненты » 2Работа с Формой (Диалог) и её элементами » 1
Встроенные Функции » 20Работа с Числами » 9
Группы расчетов » 1Регистры » 30
Диаграмма » 1Регулярные выражения » 11
Документы » 5Системные Ошибки » 4
Журналы расчетов » 14Список Справочника, Документов, Регистров » 1
Конвертация данных, Обмен, Перенос » 2Справочники » 18
Метаданные » 7Табличный документ » 6
Операция » 2Штрих-код (barcode) » 2
Категория: Работа с Числами
Версии: 7.x 8.x

ПарСумма - сумма, число Функция глРубКоп(ПарСумма) Экспорт Если Число(ПарСумма)=0 Тогда Возврат "руб. коп." КонецЕсли; Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"ЧЦ=2; ЧВН=")+" коп." КонецФункции //Пример обра
Подробнее  Разместил: E_Migachev  Дата: 05.05.2009  Прочитано: 13351  Комментарий: 1
0 
Распечатать
Категория: Администрирование
Версии: 7.x

В XP или 2000 надо положить v7plus.dll в каталог, где установлена сама 1С (по умолчанию C:Program Files1cv77BIN), удалить dll из каталогов баз и один раз запустить любую из баз под пользователем с правами администратора компьютера. Все эти дейс
Подробнее  Разместил: E_Migachev  Дата: 30.04.2009  Прочитано: 110545  Комментарии: 10
+4 
Распечатать
Категория: Встроенные Функции
Версии: 7.x 8.x 8.2 УП

//Функция формирует удобное для чтения представление значений. // Примеры форматирования чисел ЗначФормат = Формат(123456.789, " ЧЦ=10; ЧДЦ=2" ); // ЗначФормат = " 123 456,79" ЗначФормат = Формат(123456.789, " ЧГ=0; ЧДЦ=2" ); // Знач
Подробнее  Разместил: E_Migachev  Дата: 28.04.2009  Прочитано: 192592  Комментарии: 2
+19 
Распечатать
Категория: Встроенные Функции
Версии: 7.x 8.x 8.2 УП

Режим = РежимДиалогаВопрос.ДаНетОтмена; Ответ = Вопрос(" Выполнить?" , Режим, 0); Если Ответ =КодВозвратаДиалога.Да Тогда Сообщить(" Выполнено" ); ИначеЕсли Ответ = КодВозвратаДиалога.Нет Тогда Сообщить(" Не выполнено" ); КонецЕсли; Режим =
Подробнее  Разместил: E_Migachev  Дата: 28.04.2009  Прочитано: 111969  Комментарии
+5 
Распечатать
Категория: Работа с Числами
Версии: 7.x 8.x

КолВо = 1; Если ВвестиЧисло(КолВо, "Введите количество", 10, 2) Tогда // обработка введенного количество КонецЕсли; Если ВвестиЧисло(Ном, "Введите номер приказа", 5, 0, 10) = 1 Тогда ВыбДок = СоздатьОбъект("Документ.Приказ"); ВыбДок.Найти
Подробнее  Разместил: E_Migachev  Дата: 28.04.2009  Прочитано: 35184  Комментарии
+1 
Распечатать
Категория: Работа с Текстом (Строкой)
Версии: 7.x 8.x

Текст = ""; Подсказка = "Введите текст напоминания"; Если ВвестиСтроку(Текст,Подсказка, 0, истина) Тогда // запомнить текст напоминания КонецЕсли; НК = ""; Если ВвестиСтроку(НК, "Введите код продукции", 40, 1, 9) = 1 Тогда Koд = HK;
Подробнее  Разместил: E_Migachev  Дата: 28.04.2009  Прочитано: 32508  Комментарии
0 
Распечатать
Категория: Перечисления
Версии: 7.x 8.x

// В 8-ой версии нет такой фунции, но можно сделать так: ЗначПер=Перечисления.Важность.Средняя; //Установим перечисление предлагаемое выбрать по умолчанию Если ВвестиЗначение(ЗначПер,"Выберите важность:") тогда Сообщить(ЗначПер); //обработка в
Подробнее  Разместил: E_Migachev  Дата: 28.04.2009  Прочитано: 27822  Комментарии
+2 
Распечатать
Категория: Встроенные Функции
Версии: 7.x 8.x

//Пример универсального ввода значения Перем ВыбЗнач; Массив = Новый Массив; Массив.Добавить(Тип("Число")); Массив.Добавить(Тип("Строка")); Массив.Добавить(Тип("Дата")); КЧ = Новый КвалификаторыЧисла(12,2); КС = Новый КвалификаторыСтроки(20
Подробнее  Разместил: E_Migachev  Дата: 28.04.2009  Прочитано: 40358  Комментарии
0 
Распечатать
Категория: Работа с Датами (Временем)
Версии: 7.x 8.x

ДатаНапоминания = РабочаяДата; Подсказка = "Введите дату и время"; ЧастьДаты = ЧастиДаты.ДатаВремя; Если ВвестиДату(ДатаНапоминания, Подсказка, ЧастьДаты) Тогда // обработка даты напоминания КонецЕсли Если ВвестиДату(Д, "Введите дату ссуды
Подробнее  Разместил: E_Migachev  Дата: 28.04.2009  Прочитано: 36004  Комментарии
+1 
Распечатать
Категория: Работа с Датами (Временем)
Версии: 7.x 8.x

Подробнее  Разместил: E_Migachev  Дата: 27.04.2009  Прочитано: 66700  Комментарии
+8 
Распечатать
Всего 365 на 37 страницах по 10 на каждой странице