helpf.pro
Регистрация
FAQ 1С 7.x » Категорий: 40
Найти...

Все версии7.x8.x ОП8.2 УП8.3 УПВидео   Добавить FAQ
1С Бухгалтерия 2.0 » 5Отчеты » 2
1С Зарплата и Управление Персоналом 2.5 » 4Перечисления » 1
1С Общие вопросы - Обычные формы » 23Полезные, Универсальные Функции » 28
1С Управление торговлей 10.3 » 1Пользователь, роль доступа, интерфейс » 4
COM-объекты, WMI, WSH » 24Работа с Microsoft Office и OpenOffice » 30
HTML, JS, VML » 4Работа с Датами (Временем) » 13
OLE, ActiveX » 2Работа с Интернет, Почтой (Mail), FTP » 4
XML, DBF, TXT, CSV » 7Работа с Таблицей Значений » 1
Администрирование » 52Работа с Текстом (Строкой) » 7
Виды расчетов » 6Работа с Типами данных » 1
Виды Субконто » 2Работа с Файлами и Каталогами » 6
Внешние компоненты » 2Работа с Формой (Диалог) и её элементами » 1
Встроенные Функции » 20Работа с Числами » 9
Группы расчетов » 1Регистры » 30
Диаграмма » 1Регулярные выражения » 11
Документы » 5Системные Ошибки » 4
Журналы расчетов » 14Список Справочника, Документов, Регистров » 1
Конвертация данных, Обмен, Перенос » 2Справочники » 18
Метаданные » 7Табличный документ » 6
Операция » 2Штрих-код (barcode) » 2
Категория: Полезные, Универсальные Функции
Версии: 7.x 8.x

Функция глРазложить(Знач Стр, Разделитель = " ," ) Экспорт СЗ = СоздатьОбъект(" СписокЗначений" ); Если Разделитель = " " Тогда Стр = СокрЛП(Стр); Пока 1=1 Цикл Поз = Найти(Стр,Разделитель); Если Поз=0 Тогда СЗ.ДобавитьЗначение(Стр); Воз
Подробнее  Разместил: E_Migachev  Дата: 18.12.2008  Прочитано: 51005  Комментарии: 3
+2 
Распечатать
Категория: Полезные, Универсальные Функции
Версии: 7.x 8.x 8.2 УП

НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = " " ;
Подробнее  Разместил: E_Migachev  Дата: 18.12.2008  Прочитано: 84927  Комментарии: 3
+6 
Распечатать
Категория: Встроенные Функции
Версии: 7.x

// Присвоить значение переменной по ее имени. // в глоб.модуль: Функция Присвоить(Чему,Что) Экспорт Чему = Что; Возврат ""; КонецФункции // варианты вызова: // Шаблон(" "); // Шаблон(" "); // Пример: пусть у нас на форме есть 5 числовых рек
Подробнее  Разместил: E_Migachev  Дата: 11.12.2008  Прочитано: 19732  Комментарии
0 
Распечатать
Категория: Полезные, Универсальные Функции
Версии: 7.x

Процедура глЗаполнитьШапку(Конт, Скопирован=0) Экспорт ... //Блокировка ввода новых документов СтатусВозврата(0); ... КонецПроцедуры Хотя наиболее правильно будет изменять права пользователей, т.к. необходимо будет установить запрет и на изме
Подробнее  Разместил: E_Migachev  Дата: 11.12.2008  Прочитано: 12177  Комментарии
0 
Распечатать
Категория: Администрирование
Версии: 7.x

Пример пакетного файла: Output=" D:Типовые конфигурации1SBBDemolog.txt" Quit=1 SaveData=1 SaveToFile=" D:Типовые конфигурации1SBBDemoarch.zip" Ярлык для запуска базы и выполнения файла пакетного режима: Server1cv77BIN1cv7s.exe co
Подробнее  Разместил: E_Migachev  Дата: 11.12.2008  Прочитано: 16869  Комментарии
0 
Распечатать
Категория: Администрирование
Версии: 7.x

Изменить информацию в файле 1SSYSTEM.DBF DBSETUUID = " 00000000-0000-0000-0000-000000000000" Можно, для надежности сменить и остальные поля на: EVENTIDTA = " 0" DBSIGN = " " SNAPSHPER = " C" Затем удалить файлы 1SDBSET.DBF, 1SDWNLDS.DBF, 1S
Подробнее  Разместил: E_Migachev  Дата: 11.12.2008  Прочитано: 11864  Комментарии
0 
Распечатать
Категория: Администрирование
Версии: 7.x

Подробнее  Разместил: E_Migachev  Дата: 11.12.2008  Прочитано: 12810  Комментарии
0 
Распечатать
Категория: OLE, ActiveX
Версии: 7.x

Наиболее эффективно это можно сделать с помощью объектов OLE Automation , работа с которыми осуществляется при помощи: sp_OACreate, sp_OAGetProperty, sp_OASetProperty, sp_OAMethod, sp_OAGetErrorInfo, sp_OADestroy (подробное описание есть в http://te
Подробнее  Разместил: E_Migachev  Дата: 11.12.2008  Прочитано: 15097  Комментарии
0 
Распечатать
Категория: Полезные, Универсальные Функции
Версии: 7.x

create function base36_to_base10 (@base36 char(6)) returns char(10) as begin if @base36 is null return null if rtrim(@base36)=0 return  0 declare @base10 char(10) declare @ch char(1) declare @int int declare @bigint bigint declare @len
Подробнее  Разместил: E_Migachev  Дата: 11.12.2008  Прочитано: 12851  Комментарии
0 
Распечатать
Всего 365 на 37 страницах по 10 на каждой странице