helpf.pro
Регистрация
 +1 
Распечатать

1С 7.x : Ввести перечисление, выбор перечисления

Код 1C v 8.х
 
// В 8-ой версии нет такой фунции, но можно сделать так:
ЗначПер=Перечисления.Важность.Средняя; //Установим перечисление предлагаемое выбрать по умолчанию
Если ВвестиЗначение(ЗначПер,"Выберите важность:") тогда
Сообщить(ЗначПер); //обработка выбора
КонецЕсли;


Код 1C v 7.x
 
Процедура УстПризнак1()
ВыбПризн = Перечисление.ТипСотрудника.Штатный;
Если ВвестиПеречисление(ВыбПризн, "Выберите тип") > 0 Тогда
Тип = ВыбПризн;
Иначе
Тип = Перечисление.ТипСотрудника.Штатный;
КонецЕсли;
КонецПроцедуры

Процедура УстПризнак2()
ВыбПризн = "ТипСотрудника";
Если ВвестиПеречисление(ВыбПризн, "Выберите тип") > 0 Тогда
Тип = ВыбПризн;
Иначе
Тип = Перечисление.ТипСотрудника.Штатный;
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 22310
 +1 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 11
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который выпускает компания 1С . Что такое
Автоматическое резервное копирование 1С:Предприятия в облако с помощью ПО Effector Saver 3
Всем известно, для большей гарантии восстановления важных данных, необходимо копировать архивы в несколько мест хранения. Отдельный диск может помочь в случае порчи основного, но в случае если устройство будет потеряно или украдено, он будет так же
Автоматическое резервное копирование 1С:Предприятия в облако с помощью ПО Effector Saver 0
Всем известно, для большей гарантии восстановления важных данных, необходимо копировать архивы в несколько мест хранения. Отдельный диск может помочь в случае порчи основного, но в случае если устройство будет потеряно или украдено, он будет так же
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 59
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Выбор запросом элементов справочника и Загрузка в Документ 0
Запрос = СоздатьОбъект(" Запрос" ); ТекстЗапроса = " //{{ЗАПРОС(Сформировать) //|Период с ВыбНачПериода по ВыбКонПериода; |Обрабатывать НеПомеченныеНаУдаление; |Номенклатура = Справочник.Номенклатура.ТекущийЭлемент; |Группировка Номенклатура
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.