helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Процедура заполняет WORD шаблон из СпискаЗначений

Заполняет Вордовский шаблон из СпискаЗначений
Вставляется в виде обрабтки. При открытии передается СЗ первым значением идет WORD, в строковом представлеии наименование файла шаблона. Затем идентификаторы закладок (поля) в тексте шаблона - в представлении что подставить.
Сперва хотел сделать что-то универсальное Ворд-Ексель, а потом передумал. Отого такой первый параметр в списке значений

Код 1C v 7.x
 Процедура ПриОткрытии()
Перем Закладка, ТектВывода, сз;
СтатусВозврата(0);
сз = Форма.Параметр;
ФайлШаблон = ""; ОЛЕ_Объект = "";
Если ТипЗначенияСтр(сз)<>"СписокЗначений" Тогда
Сообщить("Для формирования документа передайте подготовленный список значений", "!!!"); Возврат;
ИначеЕсли сз.РазмерСписка()=0 Тогда
Сообщить("Для формирования документа передайте подготовленный список значений", "!!!"); Возврат;
Иначе
ФайлШаблон = сз.ПолучитьЗначение(1, ОЛЕ_Объект);

Если ВРег(ОЛЕ_Объект) <> "WORD" Тогда
Сообщить("OLE объект "+ОЛЕ_Объект+" не поддерживается", "!!!"); Возврат;
КонецЕсли;

Если ФС.СуществуетФайл(КаталогИБ()+"Шаблоны" + ФайлШаблон) = 0 Тогда
Сообщить("Нет файла - шаблона " + ФайлШаблон, "!!!"); Возврат;
КонецЕсли

КонецЕсли;

OLE = СоздатьОбъект(ОЛЕ_Объект+".Application");
OLE.Documents.Add(""""+КаталогИБ()+"Шаблоны" + ФайлШаблон + """");
Для Индекс = 2 по сз.РазмерСписка() цикл
ТекстВывода = сз.ПолучитьЗначение(Индекс, Закладка);
//Если OLE.ActiveDocument.Bookmarks(СокрЛП(Закладка)).Exists()=0 Тогда // Проверяем - существует ли закладка
// Сообщить("Не найдена закладка "+Закладка,"!!!" ); Продолжить;
//КонецЕсли;
Попытка
OLE.ActiveDocument.Bookmarks(СокрЛП(Закладка)).Select(); //выделим выбранную закладку
OLE.Selection.TypeText(СокрЛП(ТекстВывода)); // выведем на место выделения текст
Исключение
Сообщить("Не найдена закладка "+Закладка,"!!!" );
КонецПопытки;
КонецЦикла;

OLE.Visible=1; /// видимость - True
OLE.ActiveDocument.Activate(); /// активизировать!!!
OLE=""; /// ссылочку прибить
КонецПроцедуры


Автор: GrayT
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 6301
 0 
Распечатать
Возможно, вас также заинтересует
Использование регулярных выражений (RegExp) в 1С 1
Регулярные выражения (Regular Expressions) являются известным и мощным средством для поиска, тестирования и замены подстрок. Эта технология доступна и в 1С - через объект VBScript.RegExp. Нужный объект уже встроен в современные версии...
Как выгрузиться в EXCEL со сводными таблицами 0
Пошаговый рабочий алгоритм выгрузки в EXCEL на примере выгрузки отчетов производства за смену(Автор статьи: Funny ): (1) Нарисовать форму обработки и к кнопке запуска прицепить процедуру: Процедура...
Как сформировать новый договор, документ на основании файла, шаблона Microsoft Office Word? 0
Для заключения договоров с контрагентами разработан типовой договор (шаблон). При его оформлении (для реального контрагента) в определенные места документа вставляются данные о контрагенте. Подобные фрагменты...
Краткий пример работы с OpenOffice.org Writer и Microsoft Office Word 1
Обработка демонстрирует простейший пример работы с 2-мя текстовыми процессорами - OpenOffice.org Writer и Microsoft Office Word. Нужно запустить файл обработки, в качестве шаблона она будет использовать файл " Primer.doc" , который находится в...
Поиск строки в текстовом файле по маске 0
Есть ли возможность поиска строки в текстовом файле по маске? К примеру ХХХХ-ХХХХ-ХХХХ-ХХХХ. RegExp = Новый COMОбъект(" VBScript.RegExp" ); RegExp.IgnoreCase = Ложь; //Игнорировать регистр RegExp.Global = Истина; //Поиск всех вхождений шаблона ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.