helpf.pro
Регистрация
 +3 
Распечатать

1С 7.x : Как узнать текущие релизы 7.7 для Украины

Код 1C v 7.x
 

Функция ПолучитьВерсии()
Перем Url, HtmlTab, Строк, Р, НомСтроки, Таб, Версия, ДатаВремя;
ОчиститьОкноСообщений();
СтатусВозврата(0);
Url = "http://www.1c.ru/ukraina/support/release.jsp?time=" + _GetPerformanceCounter();
Сообщить(Url);
IE = СоздатьОбъект("InternetExplorer.Application");
IE.Navigate(Url);
Пока (IE.readyState <> 4) Или (IE.Busy = -1) Цикл
Состояние("Получение страницы... " + Url);
КонецЦикла; 
HtmlTab = IE.Document.getElementsByTagName("table").item(4).rows(0).cells(4).childNodes.item(10);
Строк = HtmlTab.rows.length;
Таб = СоздатьОбъект("ТаблицаЗначений");
Таб.НоваяКолонка("Версия" , "Строка");
Таб.НоваяКолонка("Дата" , "Дата");
Таб.НоваяКолонка("Время" , "Строка");
Таб.НоваяКолонка("Продукт" , "Строка");
Для НомСтроки = 1 По Строк Цикл
Р = HtmlTab.rows(НомСтроки - 1);
Если Р.cells.length <> 3 Тогда
Продолжить;
КонецЕсли;
Версия = Р.cells(2).innerText;
Если Найти(Версия, "7.70.") = 0 Тогда
Продолжить;
КонецЕсли;
ДатаВремя = Р.cells(0).innerText;
Таб.НоваяСтрока();
Таб.Дата = ДатаВремя;
Таб.Время = Сред(ДатаВремя, 12);
Таб.Продукт = Р.cells(1).innerText;
Таб.Версия = Версия;
КонецЦикла;
Таб.Сортировать("Дата-,Время-");
Возврат Таб;
КонецФункции


Разместил:   Версии: | 7.x |  Дата:   Прочитано: 2160
 +3 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Процедура вычисляет количество лет, месяцев и дней между двумя датами 0
// Процедура вычисляет количество лет, месяцев и дней между двумя датами // // Параметры // Дата1 – дата, первая дата (более поздняя, часто текущая, стаж определяется по состоянию на эту дату) // Дата2 – дата, вторая дата...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.