helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Пример реализации контроля ошибок при сохранение данных на дискету

При сохранении данных на дискету нужно организовать контроль ошибок, в частности проверку наличия носителя в дисководе. Сделать это можно следующим образом:

Код 1C v 7.x
 Выгружаем = 0;
Попытка
Если СтрДлина(ФС.НайтиПервыйФайл("a:\*.*")) > 0 Тогда
Если Вопрос("Дискета содержит информацию. Продолжить?","Да+Нет")= "Да" Тогда
Выгружаем = 1;
КонецЕсли;
Иначе
Выгружаем = 1;
КонецЕсли;
Если Выгружаем = 1 Тогда
//процедура сохранения данных
КонецЕсли;
Исключение
Предупреждение("Ошибка записи. Проверьте доступность носителя. (" + ОписаниеОшибки() + ")");
КонецПопытки;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5289
 0 
Распечатать
Возможно, вас также заинтересует
Выгрузка данных в Excel с установкой разных параметров 4
// Процедура выгружает из указанного справочника данные в режиме экспорта в файл в формате Microsoft Excel // с указанным именем, используя преобразование данных к типу число и типу строка; Процедура...
Как выполнить какую либо процедуру при открытии или закрытии программы? 0
В Конфигураторе, нажимаем правой кнопкой на конфигурацию: https://helpf.pro/uploads/img/_1-rSp5pRIe4R.png Модуль управляемого приложения Модуль управляемого приложения является аналогом модуля приложения, но используется для...
Как связать 1C, PHP , MySQL? 2
В современном мире люди используют Интернет не только для поиска информации, но и для приобретения каких либо товаров и услуг. Поэтому организации, например имеющие статус среднего бизнеса, стараются разместить свои...
Как сохранить поле BLOB (image) как файл на диск? 0
Наиболее эффективно это можно сделать с помощью объектов OLE Automation , работа с которыми осуществляется при помощи: sp_OACreate, sp_OAGetProperty, sp_OASetProperty, sp_OAMethod, sp_OAGetErrorInfo, sp_OADestroy (подробное описание есть в...
Кто такой Программист 1С? 2
Программист 1C – это человек, преданный своему делу, имеющий обширную теоретическую базу и обладающий практическими знаниями по использованию программ 1С. Описание профессии: 1С-программист занимается...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.