helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Как загрузить внешнюю компоненту?

Код 1C v 8.х
 Попытка 
ЗагрузитьВнешнююКомпоненту("scanopos.dll")
Исключение
Сообщить("Ошибка загрузки внешней компоненты!");
КонецПопытки;

Попытка
// Получить объект компоненты.
Объект = Новый("AddIn.Scanner");

Исключение
Сообщить("Не удалось создать объект внешней компоненты");
КонецПопытки;


Код 1C v 7.x
 //в качестве аргумента "Значение" в функцию передаётся имя файла внешней компоненты
//функция возвращает "1", если загрузка выполнена успешно, или "0", если внешнюю компоненту загрузить не получилось
Функция гВнешняяКомпонента_Загрузить(Значение) Экспорт
Состояние("Загрузка компоненты: "+Значение);
Если ЗагрузитьВнешнююКомпоненту(Значение)=1 Тогда
Возврат(1);
Иначе
Сообщить("Ошибка при загрузке компоненты: "+Значение,"!");
Возврат(0);
КонецЕсли;
КонецФункции

//этот код можно разместить в локальном модуле, в котором требуется использовать внешнюю компоненту
Если гВнешняяКомпонента_Загрузить("v7plus.dll")=0 Тогда
Возврат;
КонецЕсли;


При загрузке полезно проверять, а есть ли в наличии указанный файл DLL (к сожалению, этого не делает сам движок 1С:Предприятие 7.7).

Код 1C v 7.x
 имяф="e:\Events\Events.dll";
Если фс.СуществуетФайл(имяф)=0 Тогда
Сообщить("Файл не найден: "+имяф,"!");
КонецЕсли;
Если ЗагрузитьВнешнююКомпоненту(имяф)=0 Тогда
Сообщить("Ошибка загрузки внешней компоненты: "+имяф);
КонецЕсли;
vk=СоздатьОбъект("Addin.Events");
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 25833
 0 
Распечатать
Возможно, вас также заинтересует
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
v7plus.dll - отсутствует CLSID либо отсутствует интерфейс llnitDone 0
При выгрузке отчетности в 1С 7.7 программа ругается на v7plus.dll и указывает, что отсутствует интерфейс llritDone. Что делать? 1) Поудалять нафиг все v7plus.dll из каталогов ИБ и папок пользователей 2) Оставить только в bin каталоге и...
Выгрузка / Загрузка данных посредством XML файлов? 0
В основе работы с XML-файлами лежит технология доступа SAX, которая осуществляет считывание по одному тегу. Для этого существует два типа данных – ЗаписьXML и ЧтениеXML . Запись данных справочника в XML-файл: Запись = Новый...
Загрузка данных из XML файла в Таблицу Значений и вывод в Табличный документ 0
Перем ИмяПути,ИмяФайла; Перем xmlParser; //пример чтения xml файла. Функция УстановитьКомпоненту() Если ЗагрузитьВнешнююКомпоненту(КаталогИБ()+" ExtFormsv7plus.dll" )=0 Тогда Если ЗагрузитьВнешнююКомпоненту(" v7plus.dll" )=0 Тогда ...
Запуск 1С:Предприятия 7.7 под Windows 7 0
Установка 1С 7.7 под Windows 7 : Установщик 1С 7.7 является 16-битным приложением, а в Windows 7 отключена поддержка таких программ. Поэтому я взял другой установщик 1С, 32-битный(Ищите в интернет или спросите у Франчайзи). Запустил...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.