helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Как сформировать, вывести на печать таблицу, табличный документ

Код 1C v 8.х
  //Получение макета и областей вывода
Макет = ПолучитьМакет("Отчет");
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьКартинки = Макет.ПолучитьОбласть("ОбластьСКартинкой")
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок = Новый ТабличныйДокумент;
//Вывод параметров в область
ОбластьЗаголовок.Параметры.ДатаНач = ДатаНач;
ОбластьЗаголовок.Параметры.ДатаКон = ДатаКон;
//Вывод области в табличный документ
ТабДок.Вывести(ОбластьЗаголовок);
//Вывод картинки
Картинка = Новый Картинка(ПутьККартинке);
// Элемент управления "Логотип" входит в коллекцию картинок области.
ОбластьКартинки.Рисунки.Логотип.Картинка = Картинка;
ТабДок.Вывести(ОбластьКартинки);
//Выведем шапку таблицы
ТабДок.Вывести(ОбластьШапкаТаблицы);
//Выведм строки из Результата запроса
ВыборкаДетали = Результат.Выбрать();
Пока ВыборкаДетали.Следующий() Цикл
//Заполним параметры значениями свойств переданного объекта. Заполняются только те параметры, имена которых совпадают с именами свойств объекта.
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
//Запишем в и область Описание примечание из запроса
ОбластьДетальныхЗаписей.Область("Описание").Примечание.Текст = ВыборкаДетали.СодержаниеСобытия;
ТабДок.Вывести(ОбластьДетальныхЗаписей);
КонецЦикла;
//Зададим параметры вывода
ТабДок.АвтоМасштаб=истина; // уместить на одну страницу
ТабДок.ТолькоПросмотр=истина;
ТабДок.ОриентацияСтраницы=ОриентацияСтраницы.Ландшафт;
ТабДок.ОтображатьСетку=Ложь;
ТабДок.ОтображатьЗаголовки=Ложь;
//Выведем полученный документ
ТабДок.Показать();


Код 1C v 7.x
  
Процедура ПросмотрДокумента()
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("РасходныйДокумент");
Секция = Таб.ПолучитьСекцию("Шапка");
Таб.ВывестиСекцию(Секция);
Секция = Таб.ПолучитьСекцию("ПодписьТаблицы");
Таб.ВывестиСекцию(Секция);
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Секция = Таб.ПолучитьСекцию("ТабличнаяЧасть");
Таб.ВывестиСекцию(Секция);
КонецЦикла;
Секция = Таб.ПолучитьСекцию("Подвал");
Таб.ВывестиСекцию(Секция);
Таб.ТолькоПросмотр(0);
Таб.Показать();
КонецПроцедуры
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 22539
 0 
Распечатать
Возможно, вас также заинтересует
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Ввести значение, ввод значения 0
//Пример универсального ввода значения Перем ВыбЗнач; Массив = Новый Массив; Массив.Добавить(Тип("Число")); Массив.Добавить(Тип("Строка")); Массив.Добавить(Тип("Дата")); КЧ = Новый КвалификаторыЧисла(12,2); КС = Новый...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.