helpf.pro
Регистрация
 +1 
Распечатать

1С 7.x : Функции Шаблон и ФиксШаблон

Шаблон
Функции возвращают строковое значение, сформированное в соответствии с заданным параметром <Строка_шаблон>, заменив в ней все встро­енные выражения, заключенные в квадратные скобки, на их строковые значе­ния.
Строковое значение параметра <Строка_шаблон> обрабатывается сле­дующим образом: символы "[" , "]" (квадратные скобки) являются специаль­ными символами, которые выделяют поля, содержащие встроенные выражения. Выделенные поля фиксируют свою длину с учетом ограничивающих скобок. Например:
Имя Клиента [Имя], телефон: [Телефон]

После встроенного выражения может стоять символ "#", после которого следует Форматная_строка описанная в функции Формат. В этом случае в данное поле будет проставлен результат выражения, обработанный функцией Формат.

Код 1C v 7.x
 
Стр = Шаблон("Это название услуги: [Услуга.Наименование]");
// выдает: "Это название услуги: Доставка Товара"



ФиксШаблон

В отличие от функции Шаблон, поля замещаются значениями выражений с со­хранением своей длины в символах, то есть обрезаются, если поле короче ре­зультата вычисления выражения и дополняются пробелами если длиннее. Если результат числовой, то в границах поля строка прижимается к правой границе.

Код 1C v 7.x
 
// ниже - пример с дополнением пробелами
Стр = ФиксШаблон("Это название услуги [Услуга.Наименование]");
// выдает: "Это название услуги Доставка Товара"
// далее - с сокращением строки
Стр = ФиксШаблон("Это название услуги [Услуга.Наименование]");
// выдает: "Это название услуги Упаковка товара"


Примеры вспомогательных функций для вычисления выражений с помощью системной функции Шаблон():
Код 1C v 7.x
 
// Возвращает объект любого типа. По сути является универсальной, но
// работает дольше чем _Вычислить(), поэтому рекомендовал бы
// использовать ее когда нужно вернуть именно объект
Функция _ВычислитьОбъект( Выражение ) Экспорт
Возврат ЗначениеИзСтроки(Шаблон( "[ЗначениеВСтроку("+ Выражение+")]"));
КонецФункции

// Возвращает число. Использую ее когда нужно получить результат выполнения
// лок. функции, которые обычно возвращают 0/1 или когда просто нужно вызвать
// лок. функцию из глоб. модуля
Функция _Вычислить( Выражение) Экспорт
Возврат Число(Шаблон( "["+ Выражение+ "]"));
КонецФункции
Вызов функции осуществляется так:
_Вычислить( "ИмяЛокФункции()");

// Возвращает строку. Функцию удобно использовать когда нужно получить значение
// лок. переменной в гл. модуле
Функция _ВычислитьСтроку( Выражение) Экспорт
Возврат Строка(Шаблон( "["+ Выражение+ "]"));
КонецФункции
Вызов функции осуществляется так:
глПерем= _ВычислитьСтроку( "ЛокПерем");

// Присвоение. Функция используется для присвоения значений локальным переменным из гл. модуля
Функция _Присвоение ( Приемник ,Источник) Экспорт
Попытка
Приемник = Источник ;
Исключение
КонецПопытки;
КонецФункции
Функция вызывается примерно так:
_Вычислить ("_Присвоение(ЛокПерем,глПерем)" );
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 7465
 +1 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.