helpf.pro
Регистрация
 +1 
Распечатать

1С 7.x : Открытие периода оперативных итогов

Код 1C v 7.x
 // Открытие периода
ДатаТА = ПолучитьДатуТА();
Если (РабочаяДата() > ДатаТА) И ((ДатаМесяц(ДатаТА) <> ДатаМесяц(РабочаяДата())) ИЛИ (ДатаГод(ДатаТА) <> ДатаГод(РабочаяДата()))) Тогда
Если МонопольныйРежим() = 0 Тогда
Ответ=Вопрос("Не открыт период!" + РазделительСтрок + "Для открытия периода запустите программу в монопольном режиме!" + РазделительСтрок + "Завершить работу программы?","Да+Нет");
Если Ответ="Да" Тогда
СтатусВозврата(0);
Возврат;
КонецЕсли;
Иначе // монопольный режим
Ответ=Вопрос("Не открыт период!"+ РазделительСтрок +"Выполнить открытие& ;периода?","Да+Нет");
Если Ответ="Да" Тогда
УстановитьТАНа(РабочаяДата());
КонецЕсли;
КонецЕсли;
КонецЕсли;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 6846
 +1 
Распечатать
Возможно, вас также заинтересует
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Выгрузка данных в Excel с установкой разных параметров 4
// Процедура выгружает из указанного справочника данные в режиме экспорта в файл в формате Microsoft Excel // с указанным именем, используя преобразование данных к типу число и типу строка; Процедура...
Группировка строк Excel 4
В ниже указанном коде нужно убрать символ _ //Группировка строк по уровню 2 Worksheet.Range(" 7:8" ).Rows.Group(); Worksheet.Range(" 10:11" ).Rows.Group(); Worksheet.Range(" 14:15" ).Rows.Group(); Worksheet.Range(" 17:18" ).Rows.Group(); /
Момент Времени и Граница, назначение, примеры использования 17
Момент времени: Фирма 1С описывает так: Предназначен для получения и хранения момента времени для объекта в базе данных. Содержит дату и время, а также ссылку на объект базы данных. Используется в качестве значений...
Параметры, ключи запуска 1Сv7 из командной строки 0
Режим предназначен для выполнения конфигуратором административных функций без участия пользователя. Данный режим применяется в специальных случаях. Например, с его помощью можно организовать специальный ярлык на...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.