helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Расчет начислений по сотруднику, подразделени, документу

Код 1C v 7.x
 //   Посчитаем все начисления текущего сотрудника за январь:
ВсегоНачислено = 0;
ЖЗ.ВыбратьЗаписиПоОбъекту (ТекСотр, ДатаНач, ДатаКон);
Пока ЖЗ.ПолучитьЗапись()=1 Цикл
Если ЖЗ.ВидРасч.ВходитВГруппу(ГруппаРасчетов.ВсеНачисления)=1 Тогда
ВсегоНачислено = ВсегоНачислено + ЖЗ.Результат;
КонецЕсли;
КонецЦикла;

// Теперь рассчитаем все записи текущего сотрудника, введеные в текущем месяце:
ЖЗ.ВыбратьПериодПоОбъекту (ТекСотр, ДатаНач);
Пока ЖЗ.ПолучитьЗапись()=1 Цикл
ЖЗ.Рассчитать();
КонецЦикла;

/// Рассчитаем все записи по документу, независимо от того, в каком расчетном периоде записи порождались:
ЖЗ.ВыбратьЗаписиПоДокументу (ВыбрДокумент);
Пока ЖЗ.ПолучитьЗапись()=1 Цикл
ЖЗ.Рассчитать();
КонецЦикла;

// Рассчитаем все записи по указанному подразделению. В журнале расчетов указана графа отбора "Подразделение".
ТекПер = ЖЗ.ТекущийПериод();
ЖЗ.ВыбратьПоЗначению ("Подразделение",ВыбрПодразделение, ТекПер, ТекПер);
Пока ЖЗ.ПолучитьЗапись()=1 Цикл
ЖЗ.Рассчитать();
КонецЦикла;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 4460
 0 
Распечатать
Возможно, вас также заинтересует
Выбрать все движения регистра по документу 0
Процедура Взаиморасчеты(ВыбКлиент, ДатаНачало, ДатаКонец) // Создание Таблицы для выходного отчета Заг = " Неизвестно." ; Таб = СоздатьОбъект(" Таблица" ); Клн = СоздатьОбъект(" Справочник.Клиенты" ); ...
Как в форме списка журнала расчетов Зарплата вывести только записи, относящиеся к Документу 0
процедура ПриОткрытии() // Предопределенная процедура перем док; док = СоздатьОбъект(" Документ.Премия" ); // Метод Выбрать вызывает диалог для выбора документа // Если документ не выбран если док.Выбрать(" Выберите...
Как вывести все зарегистрированные в текущем периоде расчеты (объект, ВР и результат) Сотрудников 0
сСотр_2 = СоздатьОбъект(" Справочник.Сотрудники" ); если сСотр_2.НайтиПоНаименованию(" 02 Цех" , 0) = 0 тогда Предупреждение(" Второй цех не найден." ); возврат; конецЕсли; жз = СоздатьОбъект(" ЖурналРасчетов.Зарплата" ); пер =...
Как вывести все расчеты, относящиеся к выбранному Документу 0
док = СоздатьОбъект(" Документ.Премия" ); // Метод Выбрать вызывает диалог для выбора документа // Если документ не выбран если док.Выбрать(" Выберите документ" ) = 0 тогда Предупреждение(" Документ не выбран." ); возврат; ...
Как удалить все расчеты, относящиеся к выбранному Документу 0
док = СоздатьОбъект(" Документ.Премия" ); // Метод Выбрать вызывает диалог для выбора документа // Если документ не выбран если док.Выбрать(" Выберите документ" ) = 0 тогда Предупреждение(" Документ не выбран." ); возврат; ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.