helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Чтение RTF файлов через OpenOffice.

Для 8.х заменить СоздатьОбъект( на Новый COMОбъект(
Код 1C v 7.x
 // Пример от  Jaap Vduul 
// Пример чтения таблицы из OpenOffice:
// =====================================
ServiceManager = СоздатьОбъект("com.sun.star.ServiceManager");
Desktop = ServiceManager.createInstance("com.sun.star.frame.Desktop");
script = СоздатьОбъект("ScriptControl");
script.Language = "vbs";
script.AddCode
(
"Dim Parameters()
|
|Sub InitParameters(Size)
|
| Erase Parameters
|
| If Size > 0 Then
| Redim Parameters(Size - 1)
| End If
|
|End Sub
|
|Sub SetParameter(ServiceManager, Name, Value, Index)
|
| Set PropertyValue = ServiceManager.Bridge_GetStruct(""com.sun.star.beans.PropertyValue"")
| PropertyValue.Name = Name
| PropertyValue.Value = Value
|
| Set Parameters(Index) = PropertyValue
|
|End Sub
|
|Sub SetBooleanParameter(ServiceManager, Name, Value, Index)
|
| SetParameter ServiceManager, Name, Cbool(Value), Index
|
|End Sub
|
|Function LoadDocument(ComponentLoader, URL, TargetFrameName, SearchFlags)
|
| Set LoadDocument = ComponentLoader.loadComponentFromURL(URL, TargetFrameName, SearchFlags, Parameters)
|
|End Function
|
|Sub CloseDocument(Document)
|
| Document.Close True
|
|End Sub"
);

script.Run("InitParameters", 2);
script.Run("SetBooleanParameter", ServiceManager, "ReadOnly", 1, 0);
script.Run("SetBooleanParameter", ServiceManager, "Hidden", 1, 1);

URL = ПреобразоватьВURL(КаталогПриказов + НомерПриказа + ".rtf");
Документ = script.Run("LoadDocument", Desktop, URL, "_blank", 0);
Таблица = Документ.TextTables.getByIndex(0); // ссылка на первую таблицу

ВсегоСтрок = Таблица.getRows().getCount();
ВсегоСтолбцов = Таблица.getColumns().getCount();

Для ИндексСтроки = 1 По (ВсегоСтрок - 1) Цикл // ИндексСтроки = 1, т.к. пропускаем заголовок
Для ИндексСтолбца = 0 По (ВсегоСтолбцов - 1) Цикл
Ячейка = Таблица.getCellByPosition(ИндексСтолбца, ИндексСтроки);
ТекстЯчейки = Ячейка.getString();
КонецЦикла;
КонецЦикла;

script.Run("CloseDocument", Документ);
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 13577
 0 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 6
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р, НомСтроки, НомЯче
COM-подключение к базе 7.7 из 8.2 1С 6
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе=" D:ВашаБаза1с77" ; Пользователь=
Cклонения по падежам 6
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = " " ;
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура РасчетШириныКолонок(Табличный
Алгоритм шифрования RC4 1
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации алгоритма шифрования RC4 на встроенном яз
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.