helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Как в 7.7 прочитать файл *.csv в UTF-8

Код 1C v 7.x
 Процедура Сформировать()
Перем Имя,Путь;
Если ФС.ВыбратьФайл(0,Имя,Путь,"","*.*|*.*","*")=0 Тогда
Возврат;
КонецЕсли;
Файл=Путь+Имя;
Стрим=СоздатьОбъект("ADODB.Stream");
Стрим.Type=2;
Стрим.charset="windows-1251";
Стрим.Open();
Стрим.LoadFromFile(Файл);
Стрим.charset="utf-8";
Стр=Лев(Стрим.ReadText(),255);
Сообщить(Стр);
КонецПроцедуры

// еще способ
Процедура Сформировать()
Перем Имя,Путь;
Если ФС.ВыбратьФайл(0,Имя,Путь,"","*.*|*.*","*")=0 Тогда
Возврат;
КонецЕсли;
Файл=Путь+Имя;
УТФ16=КаталогВременныхФайлов()+_GetPerformanceCounter()+"-unicode.txt";
ЦП1251=КаталогВременныхФайлов()+_GetPerformanceCounter()+"-cp1251.txt";
БАТ=КаталогВременныхФайлов()+_GetPerformanceCounter()+".bat";
Стр="@echo off
|chcp 1251 > nul
|chcp 65001 |>> """+УТФ16+""" cmd /u /c ""type """+Файл+""" & chcp 1251 > nul""
|chcp 1251 > nul
|type """+УТФ16+""" > """+ЦП1251+"""
|chcp 866 > nul";
Текст=СоздатьОбъект("Текст");
Текст.ДобавитьСтроку(Стр);
Текст.Записать(БАТ);
КомандаСистемы(БАТ);
Текст=СоздатьОбъект("Текст");
Текст.Открыть(ЦП1251);
Для Сч=1 По Текст.КоличествоСтрок() Цикл
Сообщить(Лев(Текст.ПолучитьСтроку(Сч),255));
КонецЦикла;
ФС.УдалитьФайл(УТФ16);
ФС.УдалитьФайл(ЦП1251);
ФС.УдалитьФайл(БАТ);
КонецПроцедуры


Посмотрите еще:
Функции перекодировки текста в/из UTF-8 штатными средствами 1с 7.7
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 8818
 0 
Распечатать
Возможно, вас также заинтересует
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Быстрый перенос списка баз с одного компьютера на другой 0
Для 8.1 : 1. Список баз 8.1 можно сохранять в файл.Для этого правой кнопкой мыши по корневому элементу " Информационные базы " , далее " Сохранить ссылку в файл " . 2. Получаем файл с расширением v8i , это текстовый файл в...
Ввести строку, ввод текста 0
Текст = ""; Подсказка = "Введите текст напоминания"; Если ВвестиСтроку(Текст,Подсказка, 0, истина) Тогда // запомнить текст напоминания КонецЕсли; НК = ""; Если ВвестиСтроку(НК, "Введите код продукции", 40, 1, 9) = 1 Тогда Koд...
Выбор оптимального алгоритма для разбора строки в массив 0
Столкнулся с проблемой: ПолучитьСтрокуПоНомеру() медленно отрабатывает на входных данных 100 000 строк. Как сделать бытсрее? // Пример Defender aka LINN ВремяНачала = ТекущаяДата(); Сообщить(" Обработка начата: " + ВремяНачала); ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.