helpf.pro
Регистрация
 +1 
Распечатать

1С 7.x : Краткий пример работы с OpenOffice.org Writer и Microsoft Office Word

Обработка демонстрирует простейший пример работы с 2-мя текстовыми процессорами - OpenOffice.org Writer и Microsoft Office Word. Нужно запустить файл обработки, в качестве шаблона она будет использовать файл "Primer.doc", который находится в одном каталоге с обработкой: Скачивать файлы может только зарегистрированный пользователь!

Файл Шаблона - Primer.doc:
От: {Организация}
Кому: {Контрагент}
Ждем акт сверки взаиморасчетов!
Директор /{Директор}/

Необходимо заменить в шаблоне ключевые слова в скобках {}, на указанные значения, вот примерный код обработки:
Код 1C v 7.x
 
//рдТаблицаЗамен - Таблица значений:
// {Организация} ООО "Контора"
// {Контрагент} ООО "Должник"
// {Директор} Дядя Вася
ПечатьИзШаблона(рдТаблицаЗамен, "Primer.doc");

// Функция преобразует Windows имя файла в URL OpenOffice
Функция ПреобразоватьВURL(ИмяФайла)
Возврат "file:///" + СтрЗаменить(ИмяФайла, "\", "/");
КонецФункции

Функция ОбработкаФайлаШаблона(ИмяШаблона) Экспорт

ИмяФайла = КаталогВременныхФайлов() + "doc.tmp";
Путь = ""; Имя = "";
ФайлОбработки = РасположениеФайла(Путь, Имя);

КаталогШаблонов = Путь;
ПолноеИмяШаблона = КаталогШаблонов + ИмяШаблона;

РезультатОбработки = 0;

// Проверка на существование
ЕстьШаблон = 0;
Если ФС.СуществуетФайл(КаталогШаблонов + ИмяШаблона) = 0 Тогда
Сообщить("Файл " + ИмяШаблона + " не найден в каталоге шаблонов печатных форм! Обратитесь к системному администратору!", "!!!");
Иначе
ЕстьШаблон = 1;
КонецЕсли;

// Копирование во временный каталог

Если ЕстьШаблон = 1 Тогда
ФС.КопироватьФайл(ПолноеИмяШаблона, ИмяФайла, 0);
КонецЕсли;

// Проверка копирования

Если ФС.СуществуетФайл(ИмяФайла) = 1 Тогда
РезультатОбработки = 1;
Иначе
Сообщить("Не удалось скопировать шаблон во временный файл.");
КонецЕсли;

Возврат РезультатОбработки;

КонецФункции

Процедура ОткрытьТекстовыйПроцессор(ИмяФайла, ТаблицаЗамен)

ТекПроцессор = рдТекстовыйПроцессор.ПолучитьЗначение(рдТекстовыйПроцессор.ТекущаяСтрока());

Если ТекПроцессор = "OOoWriter" Тогда

// Открыть OpenOffice

ServiceManager = СоздатьОбъект("com.sun.star.ServiceManager");
Desktop = ServiceManager.createInstance("com.sun.star.frame.Desktop");


Scr = СоздатьОбъект("MSScriptControl.ScriptControl");
Scr.Language="javascript";
Scr.Eval("Args=new Array()");
Args = Scr.Eval("Args");
Scr.AddObject("ServiceManager", ServiceManager);

// Откроем шаблон

ТекстовыйПроцессор = Desktop.LoadComponentFromURL(ПреобразоватьВURL(ИмяФайла), "_blank", 0, Args);

// Заменяем ключевые поля на нужные значения

Replace = ТекстовыйПроцессор.CreateReplaceDescriptor();

Для x=1 По ТаблицаЗамен.КоличествоСтрок() Цикл

Replace.SearchString = ТаблицаЗамен.ПолучитьЗначение(x, 1);
Replace.ReplaceString = ТаблицаЗамен.ПолучитьЗначение(x, 2);
ТекстовыйПроцессор.ReplaceAll(Replace);

КонецЦикла;

Иначе

// Открываем MS Office Word

Попытка
ТекстовыйПроцессор = СоздатьОбъект("Word.Application");
Исключение
Сообщить("Не удалось создать объект Microsoft Office Word!", "!!!");
Возврат;
КонецПопытки;

// Открываем шаблон

ТекстовыйПроцессор.Visible = 0;
ТекстовыйПроцессор.Documents.Open(ИмяФайла,, -1);
Fnd = ТекстовыйПроцессор.ActiveDocument.Range().Find;
Fnd.ClearFormatting();
Fnd.Forward = -1;

// Заменяем ключевые поля на нужные значения

ТаблицаЗамен.ВыбратьСтроки();
Пока ТаблицаЗамен.ПолучитьСтроку() = 1 Цикл
Fnd.Execute(ТаблицаЗамен.Найти,,,,,,,,, ТаблицаЗамен.Заменить, 2);
КонецЦикла;

ТекстовыйПроцессор.Visible = -1;
ТекстовыйПроцессор.Activate();

КонецЕсли;


КонецПроцедуры
//*****************************************************************************
Процедура ПечатьИзШаблона(ТаблицаЗамен, ИмяФайлаШаблона) Экспорт

// Проверим, есть ли нужный шаблон
Если ОбработкаФайлаШаблона(ИмяФайлаШаблона) = 0 Тогда
Возврат;
КонецЕсли;

ИмяФайла = КаталогВременныхФайлов() + "doc.tmp";

// Открываем в текстовом процессоре файл шаблона
ОткрытьТекстовыйПроцессор(ИмяФайла, ТаблицаЗамен);

КонецПроцедуры
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 9211
 +1 
Распечатать
Возможно, вас также заинтересует
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
Архивация баз 7.7 при помощи WinRara 0
Данный bat файл лежит в автозагрузке и при включении компьютера спрашивает о архивации. После нажатия пробела запускается архивация базы c:1CBasaOmegal1003 и в папке появляется архив Omegal_0110_2009.rar @echo off echo . echo . echo ...
Быстрая выгрузка отчетов в Excel, наложение Фильта и отображение ярлыка 0
Вместо Таб.Показать() используем глобальную функцию - и отчет показывается сразу в Excel в удобоваримом виде - с форматированием колонок по ширине, автофильтром и ярлычками листов Процедура...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.