helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Как выполнить какую либо процедуру при открытии или закрытии программы?

В Конфигураторе, нажимаем правой кнопкой на конфигурацию:
title
Модуль управляемого приложения
Модуль управляемого приложения является аналогом модуля приложения, но используется для управляемого приложения. 1С:Предприятие 8 исполняется в режиме управляемого приложения, если запущен тонкий клиент, Веб-клиент или толстый клиент и при этом установлен режим управляемого приложения либо на всю конфигурацию, либо у конкретного пользователя. В модуле управляемого приложения могут располагаться объявления переменных, процедуры, функции и тело модуля.
Кроме того, в модуле управляемого приложения могут располагаться предопределенные процедуры ПередНачаломРаботыСистемы, ПриНачалеРаботыСистемы, ПередЗавершениемРаботыСистемы, ПриЗавершенииРаботыСистемы, ОбработкаВнешнегоСобытия. Все процедуры и функции отрабатывают на клиенте. В процедурах и функциях модуля управляемого приложения доступны экспортные процедуры и функции общих модулей управляемого клиента, а также общих неглобальных серверных модулей. Процедуры, функции и переменные модуля управляемого приложения доступны из клиентской части модулей форм и команд.

Добавляем нужный нам код, например:
Код 1C v 8.2 УП
 Процедура ПриНачалеРаботыСистемы()
Сообщить("Работайте без ошибок )");
КонецПроцедуры

При закытии программы
Код 1C v 8.2 УП
 Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Работайте без ошибок )");
КонецПроцедуры

Есть еще процедуры Перед:
Код 1C v 8.2 УП
 Процедура ПередНачаломРаботыСистемы()
//или
Процедура ПередЗавершениемРаботыСистемы()



В 1С 8.1 Конфигурация - Модуль приложения
Код 1C v 8.х
 Процедура ПриНачалеРаботыСистемы()
Сообщить("все");
КонецПроцедуры

Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Пока!");
КонецПроцедуры


Так же есть процедуры Перед:
Код 1C v 8.х
 Процедура ПередНачаломРаботыСистемы()
//или
Процедура ПередЗавершениемРаботыСистемы()



В 1С 7.7 Конфигурация - Глобальный модуль
Код 1C v 7.x
 Процедура ПриНачалеРаботыСистемы()
Сообщить("все");
КонецПроцедуры

Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Пока!");
КонецПроцедуры
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 17366
 0 
Распечатать
Возможно, вас также заинтересует
Выгрузка данных в Excel с установкой разных параметров 4
// Процедура выгружает из указанного справочника данные в режиме экспорта в файл в формате Microsoft Excel // с указанным именем, используя преобразование данных к типу число и типу строка; Процедура...
Группировка строк Excel 4
В ниже указанном коде нужно убрать символ _ //Группировка строк по уровню 2 Worksheet.Range(" 7:8" ).Rows.Group(); Worksheet.Range(" 10:11" ).Rows.Group(); Worksheet.Range(" 14:15" ).Rows.Group(); Worksheet.Range(" 17:18" ).Rows.Group(); /
Как получить уникальный идентификатор объекта, GUID? 2
GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Его главная особенность — уникальность, которая позволяет создавать расширяемые сервисы и приложения без опасения конфликтов, вызванных...
Как узнать версию конфигурации и платформы 1С? 0
Иногда бывает, что нужно узнать версию платформы и конфигурации 1С и версию конфигурации. Обычно это необходимо, чтобы определить нужны ли обновления платформы или конфигурации в данный момент или если Вы...
Периодическое выполнение кода с заданным интервалом времени - ОбработкаОжидания() 0
ПодключитьОбработчикОжидания( ИмяПроцедуры , Интервал , Однократно ) Параметры: ИмяПроцедуры (обязательный) Тип: Строка. Имя процедуры, подключаемой в качестве обработчика ожидания. Интервал (обязательный) Тип:...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.