helpf.pro
Регистрация
FAQ 1С 8.x » Категорий: 61
Найти...

Все версии7.x8.x ОП8.2 УП8.3 УПВидео   Добавить FAQ
1С Бухгалтерия 2.0 » 23Полезные, Универсальные Функции » 53
1С Зарплата и Управление Персоналом 2.5 » 52Пользователь, роль доступа, интерфейс » 17
1С Общие вопросы - Обычные формы » 52Прочие вопросы » 11
1С Управление производственным предприятием » 2Работа с Microsoft Office и OpenOffice » 62
1С Управление торговлей 10.3 » 20Работа с Датами (Временем) » 54
COM-объекты, WMI, WSH » 53Работа с Деревом Значений » 11
HTML, JS, VML » 1Работа с Интернет, Почтой (Mail), FTP » 37
Linux: CentOS, Debian, Ubuntu, ALT и д.р » 4Работа с Массивом, Структурой, Соответствием » 22
OLE, ActiveX » 3Работа с Списком Значений » 5
WEB-сервисы, WS-ссылки, XDTO-пакеты » 7Работа с Таблицей Значений » 28
XML, DBF, TXT, CSV » 26Работа с Текстом (Строкой) » 31
Администрирование » 95Работа с Типами данных » 6
Бизнес-процессы » 4Работа с Файлами и Каталогами » 30
Внешние источники данных » 2Работа с Формой (Диалог) и её элементами » 77
Внешние компоненты » 3Работа с Хранилищем Значений » 12
Внешние печатные формы, отчеты и обработки заполнения » 3Работа с Числами » 22
Встроенные Функции » 59Регистры бухгалтерии » 21
Географическая схема » 9Регистры накопления » 16
Диаграмма » 12Регистры расчета » 14
Документы » 58Регистры сведений » 33
Загрузка данных в 1С » 1Регламентные задания, Фоновые задания » 1
Задачи » 4Регулярные выражения » 12
Запросы » 80Системные Ошибки » 14
Конвертация данных, Обмен, Перенос » 31Список Справочника, Документов, Регистров » 25
Константы » 7Справочники » 49
Метаданные » 8Схема Компоновки Данных » 61
Обработки » 3Табличный документ » 35
Отчеты » 1Текстовый документ » 4
Перечисления » 8Торговое оборудование » 1
Планы видов расчета » 3Штрих-код (barcode) » 5
Планы видов характеристик » 1
Категория: Работа с Типами данных
Версии: 8.x

ИмяНужногоТипа = "ДокументСсылка.РеализацияТоваров"; Если ТипЗнч(ОбрабатываемыйДокумент) = Тип(ИмяНужногоТипа) Тогда // Строки кода, выполняемые при истинности условия. КонецЕсли;
Подробнее  Разместил: E_Migachev  Дата: 11.12.2008  Прочитано: 19419  Комментарии
0 
Распечатать
Категория: Работа с Датами (Временем)
Версии: 8.x

СледующийДень = ТекущаяДата() + 60 * 60 * 24; ДобавитьМесяц(Дата(2005, 1, 31), 1); ДобавитьМесяц(Дата(2005, 2, 28), -1); КонецМесяца(ДобавитьМесяц(Дата(2005, 2, 28), -1)); Функция ПолучитьДень(ИсходнаяДата, КоличествоПрибавляемыхДней) Запрос =
Подробнее  Разместил: E_Migachev  Дата: 09.12.2008  Прочитано: 91464  Комментарии
0 
Распечатать
Категория: Работа с Датами (Временем)
Версии: 8.x

Если НачалоДня(Дата1) = НачалоДня(Дата2) Тогда Сообщить("Дни совпадают!"); КонецЕсли;
Подробнее  Разместил: E_Migachev  Дата: 09.12.2008  Прочитано: 25099  Комментарии
0 
Распечатать
Категория: Работа с Датами (Временем)
Версии: 8.x

Если ДатаПроверяемая = Дата(1, 1, 1) Тогда Сообщить("Пустая дата!"); КонецЕсли;
Подробнее  Разместил: E_Migachev  Дата: 09.12.2008  Прочитано: 34910  Комментарии
0 
Распечатать
Категория: Работа с Датами (Временем)
Версии: 7.x 8.x

Значения данного типа содержит дату григорианского календаря (с 01 января 0001 года) и время с точностью до секунды. Литералы: Строка цифр, заключенная в одинарные кавычки вида: ГГГГММДДччммсс, где: ГГГГ - четыре цифры года (включая тысячелетие
Подробнее  Разместил: E_Migachev  Дата: 09.12.2008  Прочитано: 62460  Комментарии: 2
+3 
Распечатать
Всего 1415 на 142 страницах по 10 на каждой странице