helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Табличное поле ~ Дополнительные колонки в динамическом списке

В процессе написания кода для отображения дополнительных вычисляемых полей в динамическом списке документов получились вот такие приемы (просто код, без комментариев).
Код 1C v 8.х
 Процедура ДокументСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
ТекДокумент = ДанныеСтроки.Ссылка;
СуммаДокумента = ТекДокумент.Товары.Итог("СуммаСНДС");
СуммаБезнал = ТекДокумент.Оплата.Итог("СуммаОплаты");
СуммаНал = ?(СуммаДокумента > СуммаБезнал, СуммаДокумента - СуммаБезнал, 0);
ОформлениеСтроки.Ячейки.СуммаДокумента.ОтображатьТекст = Истина;
ОформлениеСтроки.Ячейки.НаличнаяОплата.ОтображатьТекст = Истина;
ОформлениеСтроки.Ячейки.БезналичнаяОплата.ОтображатьТекст = Истина;
ОформлениеСтроки.Ячейки.СуммаДокумента.Текст = Формат(СуммаДокумента, "ЧДЦ=2; ЧН=");
ОформлениеСтроки.Ячейки.НаличнаяОплата.Текст = Формат(СуммаНал, "ЧДЦ=2; ЧН=");
ОформлениеСтроки.Ячейки.БезналичнаяОплата.Текст = Формат(СуммаБезнал, "ЧДЦ=2; ЧН=");

//Определяем наличие ПКО
Если ТекДокумент.ПолучитьОбъект().ПолучитьСвязанныйПКО() <> Неопределено Тогда
ОформлениеСтроки.Ячейки.ЕстьПКО.ОтображатьКартинку = Истина;
ОформлениеСтроки.Ячейки.ЕстьПКО.Картинка = БиблиотекаКартинок.ВыполненоУспешно32;
КонецЕсли;
КонецПроцедуры

Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
//Определяем наличие ПКО
МассивДокументов = Новый Массив;
Для каждого ТекСтрока Из ОформленияСтрок Цикл
МассивДокументов.Добавить(ТекСтрока.ДанныеСтроки.Ссылка);
КонецЦикла;
Запрос = Новый Запрос("ВЫБРАТЬ Основание ИЗ РегистрСведений.АА_СвязанныеДокументы КАК СД ГДЕ СД.Основание В (&Документы)");
Запрос.УстановитьПараметр("Документы", МассивДокументов);
Результат = Запрос.Выполнить().Выгрузить();
Для Каждого ТекСтрока Из ОформленияСтрок Цикл
Ссылка = ТекСтрока.ДанныеСтроки.Ссылка;
ТекСтрока.Ячейки.ЕстьПКО.ЗначениеКартинки = Результат.Найти(Ссылка,"Основание") <> Неопределено;
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8168
 0 
Распечатать
Возможно, вас также заинтересует
В регламентированной отчетности не печается штрих-код 1С ( EanGnivc ) 0
Установка шрифта EanGnivc В формах регламентированной отчетности, например, налоговые декларации, которые введены для предоставления отчетности, на всех листах в левом верхнем углу содержат свой уникальный штрих-код. В...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Динамическое изменение состава колонок в списке справочника 0
Сразу прошу прощения за ламерский вопрос. Тока начал работать с 8.2. Есть справочник Номенклатура, помимо реквизитов у него есть табличная часть, в которой может храниться произвольный набор элементов с названием и...
Добавление поддержки нестандартного штрих-кода в обработке ПечатьЭтикеток 0
Обработка ПечатьЭтикеток использует компоненту " 1С:Печать штрихкодов" (доступную на диске ИТС) для печати штрих-кодов(далее ШК). Эта компонента поддерживает следующие типы штрих-кодов: EAN8, EAN13, EAN128, Code39, Code128. Что делать...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.