helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как выгрузить журнал регистрации в XML-формате?

Код 1C v 8.х
 ВыгрузитьЖурналРегистрации("C:\log.xml"); 

Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
Для Каждого Пользователь из Пользователи Цикл
НовыйЭлемент = СписокПользователей.Добавить();
НовыйЭлемент.Пометка = Истина;
НовыйЭлемент.Значение = Пользователь;
НовыйЭлемент.Представление = Пользователь.Имя;
КонецЦикла;

Массив = Новый Массив;
Для Каждого Пользователь Из СписокПользователей Цикл
Если Пользователь.Пометка Тогда
Массив.Добавить(Пользователь);
КонецЕсли;
КонецЦикла;

СтруктураФильтра = Новый Структура;
СтруктураФильтра.Вставить("Пользователь", Массив);
ВыгрузитьЖурналРегистрации("C:\log.xml", СтруктураФильтра, "Дата, Пользователь, ПредставлениеСобытия");
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8116
 0 
Распечатать
Возможно, вас также заинтересует
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
SMTP greeting failure: 421 SMTP connection broken (reply) 2
Опи­са­ние ошиб­ки: С сен­тяб­ря 2014 Ян­декс.Почта, Mail.ru пе­ре­шли на про­то­кол SSL, что сде­ла­ло их еще более без­опас­ны­ми. Чтобы и даль­ше ра­бо­тать с пись­ма­ми через 1С, Вам нужно из­ме­нить их на­строй­ки и...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Автоматическая выгрузка загрузка данных используя регламентное задание 1
Для обмена данными между программами необходимо сделать следующее: 1. При помощи Конвертации Данных создать правила выгрузки данных 2. Нужно чтобы в конфигурации была обработка УниверсальныйОбменДаннымиXML ,...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.