helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Добавление в список выбора листов excel-файла с возможностью последующего к ним обращения

title

Код 1C v 8.х
 
//Реквизит "Листы" - неопределённого типа
//Реквизит "Файл" - строковой реквизит, в котором хранится путь к excel-файлу

Процедура ЗаполнитьЛисты()

ЭлементыФормы.Листы.СписокВыбора.Очистить();
Таблица = ПолучитьCOMОбъект(Файл);

Для Н = 1 По Таблица.Sheets.Count Цикл
ТекущийЛист = Строка(Таблица.Sheets(Н).Index) + ". " + Таблица.Sheets(Н).Name;
ЭлементыФормы.Листы.СписокВыбора.Добавить(ТекущийЛист);
КонецЦикла;
ЭлементыФормы.Листы.Значение = ТекущийЛист;

КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)

Если ЭлементыФормы.Листы.Значение = "" Тогда
Предупреждение("Выберите лист", 5);
Возврат;
КонецЕсли;

Таблица = ПолучитьCOMОбъект(Файл);
Индекс = Число(Сред(ЭлементыФормы.Листы.Значение, 1, Найти(ЭлементыФормы.Листы.Значение, ". ") - 1));//извлекаем порядковый номер из текущего значения списка выбора
Лист = Таблица.Sheets(Индекс);//получаем лист по порядковому номеру

//теперь обращаемся к значениям в ячейках по своему усмотрению

Строка = 1;
Столбец = 4;

КодНоменклатуры = Лист.Cells(Строка, Столбец).Value);
Номенклатура = Лист.Cells(Строка, Столбец + 1).Text);

КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6474
 0 
Распечатать
Возможно, вас также заинтересует
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Вертикальная автофиксация для СКД 0
В СКД очень не хватает возможности автофиксации строк. Обусловлено это невозможностью однозначно определить их количество в общем случае. Однако в большинстве случаев это можно сделать Обращаю ваше внимание, что...
Запуск кода в конфигурации из командной строки 0
Иногда возникает необходимость запуска кода в базе 1С из командной строки. Например, надо выполнять те или иные процедуры по расписанию, но при этом нет желания каждый раз менять конфигурацию, а хочется прописать все в...
Как очистить, сократить журнал регистрации? 0
В 1С 8.х В процессе длительной эксплуатации системы в журнале регистрации может накапливаться значительное число записей. Поэтому поддерживается возможность сокращения журнала регистрации и удаления записей,...
Как принудительно завершить работу всех пользователей информационной базы? 0
Для этого можно воспользоваться возможностью программного доступа к серверу 1С:Предприятия 8. Нужно создать COM-коннектор и выполнить метод ConnectWorkingProcess(), который позволяет подключиться к указанному серверу. Затем...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.