helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Выбор из нескольких списков документов для открытия?

Код 1C v 8.х
 Док = Метаданные.Документы; 
СписокДокументов = Новый СписокЗначений();

СписокДокументов.Добавить(Док.ПлатежноеПоручениеИсходящее, , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеПоручениеВходящее, , Ложь);
СписокДокументов.Добавить(Док.АккредитивПереданный, , Ложь);
СписокДокументов.Добавить(Док.АккредитивПолученный, , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеТребованиеВыставленное, , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеТребованиеПолученное, , Ложь);
СписокДокументов.Добавить(Док.ИнкассовоеПоручениеПереданное, , Ложь);
СписокДокументов.Добавить(Док.ИнкассовоеПоручениеПолученное, , Ложь);
СписокДокументов.Добавить(Док.ПлатежныйОрдерСписаниеДенежныхСредств, , Ложь);
СписокДокументов.Добавить(Док.ПлатежныйОрдерПоступлениеДенежныхСредств, , Ложь);

Если СписокДокументов.ОтметитьЭлементы("Укажите, какие списки документов открыть") Тогда
Для Каждого НазваниеДокумента из СписокДокументов Цикл
Если НазваниеДокумента.Пометка Тогда
ФормаСписка = Документы[НазваниеДокумента.Значение.Имя].ПолучитьФормуСписка();
ФормаСписка.Открыть();
КонецЕсли;
КонецЦикла;
КонецЕсли;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6181
 0 
Распечатать
Возможно, вас также заинтересует
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
ZIP-архив Чтение 0
Для того чтобы прочитать файлы из ZIP-архива необходимо выполнить несколько простых действий: - Открыть необходимый архив - Распаковать файлы Создание объекта ЧтениеZIPФайла можно осуществить двумя путями - создать...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Ввод данных по командировкам в программе ЗУП 0
Ввод сведений о командировках в программе 1С: Зарплата и управление персоналом 8 (ред.30) осуществляется в Разделе Кадры - Все кадровые документы - Создать - Командировка Откроется документ: Ввод сведений о...
Восстановление партионного учета в УТ 0
Проблема следующая: при выполнении стандартной обработки " проведение по партиям" , непонятно почему, но граница актуальности партионного учета не сдвигается, хотя при перепроведении документов никаких ошибок не...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.